Bug 75388 - redhat-config-packages crashes on startup
redhat-config-packages crashes on startup
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 19:20 EDT by Herrick, Andrew
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 00:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Herrick, Andrew 2002-10-07 19:20:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
when starting redhat-config-packages from the command line it crashes with
python traceback error. this did not happen when i first installed redhat 8.0. i
don't know what changed to make this error happen. the traceback that python
spits out follows:

-------- STARTS HERE --------
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile
    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence
-------- ENDS HERE --------

i hope this helps.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. type redhat-config-packages on the command line
2. hit enter
3. watch it crash :)
	

Actual Results:  the app crashed.

Expected Results:  the app used to run, i was expecting it to continue to run. :)
Comment 1 Herrick, Andrew 2002-10-07 19:58:53 EDT
i figured out what caused the problem. earlier today i installed the mozilla
.src.rpm for testing using redhat-config-packages. this seems to have replaced
the .i386.rpm in the rpm database because when i ran `rpm -q --provides mozilla`
it gave me an empty list.

i uninstalled and re-installed all of the mozilla .i386.rpm's and the problem
went away.

should it be possible to install .src.rpm's using redhat-config-packages?
Comment 2 Jeremy Katz 2002-10-11 16:35:16 EDT
No, rpmlib wasn't acting how I expected it to.  Fixed in CVS so that you can't
run into that problem anymore (both by verifying that there are provides before
iterating over them and not allowing the installation of src.rpms so that they
end up in the rpmdb)
Comment 3 John Thacker 2006-04-22 00:18:21 EDT
Long fixed, RH 8 not supported, and magicdev and s-c-p aren't shipped anymore. 
(Pirut replaced s-c-p.)  Closing.

Note You need to log in before you can comment on or make changes to this bug.