Bug 75392 - weird boot logo
weird boot logo
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 21:16 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 03:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2002-10-07 21:16:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When using the console in vesa framebuffer mode, the boot logo apears all weird.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add vga=0x303 to the kernel line of grub.conf
2.reboot
3.
	

Actual Results:  The boot logo appears all weird (striped).

Additional info:

I don't know if it's supposed to look that way, but it really looks awful to me.
Comment 1 Doug 2002-10-11 03:16:37 EDT
Yep, happened to me too.

I was booting with vga=773 (1024x768x8bpp) and video=vesa:ywrap, and the logo 
really sucks.

Some investigation has uncovered that RH changed the logo file 
(include/linux/linux_logo.h), but failed to update LOGO_H and LOGO_W in 
drivers/video/fbcon.c.  The results are that the new logo (looks like it's 
supposed to have a res of 2400x20) are not in sync with fbcon.c expected size 
of 800x60.

The other possibility is that the junk in the new linux_logo.h file has been 
corrupted somehow, because I'm still trying to figure out why RH wants a bootup 
logo with a width of 2400 - seems too big for me.

I think you can workaround this ugly logo by doing one of two things:

1. Grab linux_logo.h from RH 7.3, replace it, and rebuild the kernel.
2. Grab linux_logo.h and fbcon.c from kernel-2.4.19, replace em both, rebuild 
the kernel, then see a TUX logo instead of RH's.  :)

Basically, the bitmap for the logo in linux_logo.h must be EXACTLY synchronized 
with the #defines of LOGO_H and LOGO_W in fbcon.c - and they are NOT sync'd in 
RH 8.0.

BB.

Note You need to log in before you can comment on or make changes to this bug.