Bug 753950 - PXE installs drop to debug shell
Summary: PXE installs drop to debug shell
Keywords:
Status: CLOSED DUPLICATE of bug 738494
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-14 22:33 UTC by Dave Jones
Modified: 2015-01-04 22:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-20 12:36:47 UTC


Attachments (Terms of Use)
dmesg output with rd_debug (79.19 KB, text/plain)
2011-11-14 23:29 UTC, Dave Jones
no flags Details

Description Dave Jones 2011-11-14 22:33:08 UTC
Using the F16 pxeboot install images, I see this...

dracut: root was live:/squashfs.img, liveroot is now live:/squashfs.img
EXT4-fs (dm-0) mounted filesystem with ordered data mode. Opts: (null)
Mounted root filesystem /dev/mapper/live-rw
dracut: Warning: Signal caught!
Dropping to debug shell.

Comment 1 Dave Jones 2011-11-14 23:29:25 UTC
Created attachment 533650 [details]
dmesg output with rd_debug

dmesg output with rd_debug

Comment 2 Harald Hoyer 2011-11-15 09:49:22 UTC
ah, this is the "--loglevel=debug" kernel command line parameter, which the kernel blindly assigns to an environment variable called "--loglevel" with the value "debug". The dash shell really does not like it.

dash bug 738494
dracut bug 733674 ( seems only partially solved )

Comment 3 Harald Hoyer 2012-02-20 12:36:47 UTC

*** This bug has been marked as a duplicate of bug 738494 ***


Note You need to log in before you can comment on or make changes to this bug.