Bug 753983 - logrotate complains about insecure permissions
Summary: logrotate complains about insecure permissions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: roundcubemail
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 802811 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-15 01:49 UTC by Nerijus Baliūnas
Modified: 2012-04-01 00:27 UTC (History)
7 users (show)

Fixed In Version: roundcubemail-0.5.4-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-17 23:46:09 UTC


Attachments (Terms of Use)

Description Nerijus Baliūnas 2011-11-15 01:49:53 UTC
/etc/cron.daily/logrotate:



error: skipping "/var/log/roundcubemail/errors" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.

# ls -ld /var/log/roundcubemail
drwxrwxr-x. 2 root apache 4096 2011-09-06 18:17 /var/log/roundcubemail

BTW, it is empty:
# ls -l /var/log/roundcubemail
total 0

roundcubemail-0.5.4-1.fc16.noarch

/var/log/roundcubemail was not changed by me:
# rpm -V roundcubemail 
5S.T.....  c /etc/httpd/conf.d/roundcubemail.conf
5S.T.....  c /etc/roundcubemail/db.inc.php
5S.T.....  c /etc/roundcubemail/main.inc.php

Comment 1 Cyrus Joudieh 2011-11-15 09:03:07 UTC
Missing su in /etc/logrotate.d/roundcubemail

[root@host logrotate.d]# /etc/cron.daily/logrotate 
error: skipping "/var/log/roundcubemail/errors" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.

add the "su" under create inside the file /etc/logrotate.d/roundcubemail

[root@host logrotate.d]# cat roundcubemail 
/var/log/roundcubemail/errors {
    missingok
    notifempty
    size 30k
    create 0660 root apache
    su
}

That should fix it, and the error is not there.

[root@host logrotate.d]# /etc/cron.daily/logrotate 
[root@host logrotate.d]#

Comment 2 Jan ONDREJ 2012-03-02 08:36:08 UTC
> [root@host logrotate.d]# cat roundcubemail 
> /var/log/roundcubemail/errors {
>     missingok
>     notifempty
>     size 30k
>     create 0660 root apache
>     su
> }
> 
> That should fix it, and the error is not there.

su requires 2 parameters, user and group. Please add apache apache.

> [root@host logrotate.d]# /etc/cron.daily/logrotate 
> [root@host logrotate.d]#

Maybe you started this when logs have been already rotated.

Please, also add other files in /var/log/roundcubemail to rotation script.
You can use:

/var/log/roundcubemail/*

I am not sure, if su and create ... root are compatible.

Comment 3 Fedora Update System 2012-03-02 17:43:29 UTC
roundcubemail-0.5.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/roundcubemail-0.5.4-2.fc16

Comment 4 Fedora Update System 2012-03-02 17:43:38 UTC
roundcubemail-0.5.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/roundcubemail-0.5.4-2.fc15

Comment 5 Fedora Update System 2012-03-06 19:31:44 UTC
Package roundcubemail-0.5.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing roundcubemail-0.5.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3043/roundcubemail-0.5.4-2.fc16
then log in and leave karma (feedback).

Comment 6 Gwyn Ciesla 2012-03-13 14:49:08 UTC
*** Bug 802811 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2012-03-17 23:46:09 UTC
roundcubemail-0.5.4-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-03-18 00:01:56 UTC
roundcubemail-0.5.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Marc Bradshaw 2012-03-23 04:40:38 UTC
Using 0.5.4-2  on fc15 I am now seeing the following error from logrotate

error: roundcubemail:3 unknown option 'su' -- ignoring line

Comment 10 Nerijus Baliūnas 2012-03-23 12:08:39 UTC
It seems update should have been released for F16 only.

Comment 11 Gwyn Ciesla 2012-03-23 13:44:40 UTC
Oh, that's a new feature with 3.8.x.  Whoops.  I'll get a fix out.

Comment 12 Fedora Update System 2012-03-23 13:54:17 UTC
roundcubemail-0.5.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/roundcubemail-0.5.4-3.fc15

Comment 13 Fedora Update System 2012-04-01 00:27:39 UTC
roundcubemail-0.5.4-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.