This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 75401 - Segmentation Fault 2.4.18-13 kernel re-compile - make dep
Segmentation Fault 2.4.18-13 kernel re-compile - make dep
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: make (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 22:28 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 15:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ver_linux script output (1.09 KB, text/plain)
2002-10-07 22:30 EDT, Need Real Name
no flags Details
System information (6.48 KB, text/plain)
2002-10-07 22:37 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-07 22:28:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Error while performing make dep.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to source tree run "make mrproper".
2. Using an unchanged .config file from "make oldconfig" after system was first
upgraded to RH 8.0, run "make xconfig".
3. Save and exit without making any updates on the kernel configuration menus.
4. Run "make dep"

	

Actual Results:  Received a Segmentation fault and the following error message:

gentbl.c: In function `gentbl_psk4800':
gentbl.c:434: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[6]: *** [gentbl] Error 1
make[6]: Leaving directory
`/usr/src/linux-2.4.18-14/drivers/net/hamradio/soundmodem'
make[5]: *** [_sfdep_soundmodem] Error 2
make[5]: Leaving directory `/usr/src/linux-2.4.18-14/drivers/net/hamradio'
make[4]: *** [fastdep] Error 2
make[4]: Leaving directory `/usr/src/linux-2.4.18-14/drivers/net/hamradio'
make[3]: *** [_sfdep_net/hamradio] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.18-14/drivers'
make[2]: *** [fastdep] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.18-14/drivers'
make[1]: *** [_sfdep_drivers] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-14'
make: *** [dep-files] Error 2


Expected Results:  "make dep" should have exited with good return codes.

Additional info:

See attached file for system configuration info.
Comment 1 Need Real Name 2002-10-07 22:30:11 EDT
Created attachment 79284 [details]
ver_linux script output
Comment 2 Need Real Name 2002-10-07 22:37:57 EDT
Created attachment 79285 [details]
System information
Comment 3 Need Real Name 2002-10-07 22:48:35 EDT
Mother Board Asus - P34VX
Comment 4 Need Real Name 2002-10-07 22:53:36 EDT
Award Bios - 1005
Comment 5 Jakub Jelinek 2004-10-03 15:11:08 EDT
The kernel has built since then.

Note You need to log in before you can comment on or make changes to this bug.