This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 75403 - rpmq segfault on DB close.
rpmq segfault on DB close.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 23:11 EDT by Aleksey Nogin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 13:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-10-07 23:11:51 EDT
% rpm -qf /usr/lib/rpm/perl.req
rpm-build-4.1-1.06
Segmentation fault (core dumped)

(gdb) run -q --file /usr/lib/rpm/perl.req
Starting program: /usr/lib/rpm/rpmq -q --file /usr/lib/rpm/perl.req
[New Thread 8192 (LWP 17771)]
rpm-build-4.1-1.06

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 8192 (LWP 17771)]
0x42074005 in _int_free () from /lib/i686/libc.so.6
(gdb) bt
#0  0x42074005 in _int_free () from /lib/i686/libc.so.6
#1  0x42074a2c in free () from /lib/i686/libc.so.6
#2  0x400bde54 in db3Free () from /usr/lib/librpmdb-4.1.so
#3  0x400cf63a in db3close () from /usr/lib/librpmdb-4.1.so
#4  0x400c7c84 in rpmdbClose () from /usr/lib/librpmdb-4.1.so
#5  0x40087e78 in rpmtsCloseDB () from /usr/lib/librpm-4.1.so
#6  0x40088f42 in rpmtsFree () from /usr/lib/librpm-4.1.so
#7  0x08049708 in main ()
#8  0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

% rpm -q rpm glibc
rpm-4.1-1.06
glibc-2.2.93-5

P.S. Reproducible 100%.
Comment 1 Jeff Johnson 2002-10-08 09:00:56 EDT
What happens if you do --rebuilddb?
Comment 2 Aleksey Nogin 2002-10-08 13:29:33 EDT
Hm, somehow never though of that. --rebuilddb indeed made this go away, although
it's still not clear what caused it in the first place. This system was upgraded
from 7.2 to 8.0 (using the anaconda installer).
Comment 3 Jeff Johnson 2002-10-08 13:49:34 EDT
I can't tell what caused the problem either.

I can say that, for packages that have header-only
signatures, segfaults due to bad data retrieved
should be a thing of the past.

Note You need to log in before you can comment on or make changes to this bug.