Bug 754056 - Bash not included in list of shells (/etc/shells)
Bash not included in list of shells (/etc/shells)
Status: CLOSED DUPLICATE of bug 752827
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
16
All All
unspecified Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 04:36 EST by Andy Blanchard
Modified: 2011-11-15 04:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-15 04:51:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Blanchard 2011-11-15 04:36:51 EST
Description of problem:

Local user accounts are unable to login to VSFTP when the daemon is correctly configured and their shell is set to Bash.  The problem is resolved when the line "/bin/bash" is added to "/etc/shells" or VSFTP is configured to avoid this requirement (not a recommended configuration!).

Solution:

Add the missing line to "/etc/shells" in the next update of the package.
Comment 1 Ondrej Vasik 2011-11-15 04:51:25 EST
Please run yum reinstall bash ... there was a buggy bash update.

*** This bug has been marked as a duplicate of bug 752827 ***

Note You need to log in before you can comment on or make changes to this bug.