Bug 75408 - pts not correctly being displayed with current user
pts not correctly being displayed with current user
Status: CLOSED DUPLICATE of bug 71368
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 00:31 EDT by Kevin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 00:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin 2002-10-08 00:31:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Gnome-terminal is not correctly utilizing pseudoterminals. When firing up
gnome-terminal from the menu, it is not displayed as being logged in to the
local machine via a pts if you run the 'w' command or the 'who' command. In
previous versions, one would see themselves logged in via ptsN where N is a
number. This breaks functionality of other utilities such as write, since one
cannot write to a pts that is not available via the 'who' command.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fire up gnome-terminal from the menu
2.execute either 'w' or 'who' from the command line
3.watch as you don't see yourself on a pseudoterminal
	

Actual Results:  I wasn't able to see myself logged in on a pts unless I use ps.


Expected Results:  should display myself being logged in on ptsN from display :N


Additional info:

I haven't really looked into this too much, but other people on the mailing list
are experiencing the same problems. All default packages. I tried both options
of gnome-terminal using the --login, also tried enabling it to use wtmp, etc...
nothing works.
Comment 1 Havoc Pennington 2002-10-08 09:40:03 EDT

*** This bug has been marked as a duplicate of 71368 ***

Note You need to log in before you can comment on or make changes to this bug.