Bug 754149 - "-usbdevice tablet" no longer works
"-usbdevice tablet" no longer works
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 09:23 EST by Michael J. Chudobiak
Modified: 2013-01-09 19:32 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 08:36:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2011-11-15 09:23:42 EST
This command worked fine in F15:

/usr/bin/qemu-kvm -hda /var/lib/libvirt/images/MikeOfficeXP.img -usbdevice tablet -m 1024 -k en-us -vga qxl -spice port=5931,disable-ticketing &

However, in F16 the "-usbdevice tablet" clause no longer works. No mouse movement occurs in the Windows XP guest.

If that clause is removed, mouse movement occurs, but not in the tablet mode. (The tablet mode allows the mouse pointer to escape the spice viewer window. The non-tablet mouse mode confines the mouse to the spice viewer window until a special key sequence is pressed.)

http://blog.luboskocman.com/2011/02/getting-started-with-spice.html says that "-usbdevice tablet is deprecated but it allows you to move mouse between guest and client without having any guest tools (vdagent) installed. However it does not deal well with multiple guest displays." It should still work though, even if it is deprecated.

- Mike
Comment 1 Michael J. Chudobiak 2011-11-24 11:05:42 EST
Also observed on Ubuntu: https://bugs.launchpad.net/qemu/+bug/839790
Comment 2 Cole Robinson 2012-01-24 14:56:34 EST
Gerd, any thoughts? Maybe some upstream commit that might be a backport candidate?
Comment 3 Gerd Hoffmann 2012-01-26 03:24:37 EST
Never seen that myself, reportly going to device manager and reinstalling the device helps.  No idea what the root cause is.
Comment 4 Fedora Admin XMLRPC Client 2012-03-15 13:55:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Michael J. Chudobiak 2012-07-09 08:36:55 EDT
This issue seems to be fixed in current rawhide packages:

qemu-common.x86_64 2:1.1.0-4.fc18                                             
qemu-img.x86_64 2:1.1.0-4.fc18                                                
qemu-kvm.x86_64 2:1.1.0-4.fc18                                                
qemu-system-x86.x86_64 2:1.1.0-4.fc18

Closing bug.

- Mike

Note You need to log in before you can comment on or make changes to this bug.