Bug 75417 - Doesn't increment zone serial number
Doesn't increment zone serial number
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-bind (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 05:34 EDT by Thais Smith
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 15:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thais Smith 2002-10-08 05:34:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
redhat-config-bind doesn't increment the zone serial number when data has been changed

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-bind
2. add or delete a record in a zone
3. Choose File->Apply
	

Actual Results:  The zone has the same serial number as before

Expected Results:  The serial number should be incremented

Additional info:

This may be more of a user-interface issue, but the way the GUI is laid out, in order to change the serial number one has to select the zone, hit edit, and then hit the set button to change the S/N (which is the only field there which is not directly editable). The layout suggests that the Serial Number should not often be edited directly, which suggests to me that File->Apply should increment it if the user hasn't edited it (after all, if you have secondaries, applying the changes must include propagation, which won't happen for quite a long time if the S/N hasn't changed)

If it is intended that the user must change the S/N themselves every time it needs doing, perhaps the UI should make it more prominently editable (and provide a warning when applying changes if it hasn't been done, maybe).
Comment 1 Daniel Walsh 2002-10-09 10:02:16 EDT
Fixed in redhat-config-bind-1.9.0-2

Will be in rawhide shortly
Comment 2 Daniel Walsh 2002-10-09 10:02:46 EDT
The number should now be incremented automatically

Note You need to log in before you can comment on or make changes to this bug.