Bug 75422 - Wrong default driver and/or driver problems for the GeForce 4 video card.
Wrong default driver and/or driver problems for the GeForce 4 video card.
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-08 08:23 EDT by dfladebo
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-08 08:23:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description dfladebo 2002-10-08 08:23:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The default driver for the GeForce 4 video card is vesa, which did not work as
well as the nv driver (eg: color depth max. was 16 bit instead of 24 bit and the
video output would not center correctly for the resolution [1280x1024]
selected). This same card setup without fault for 24 bit and 1280x1024 during
the install on RH 7.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RH 8 on a system with NVIDIA GeForce 4 video card.
2. Select 1280x1024 and 24 bit color during the installation process.

Actual Results:  On boot, the system will not be able to start the Xserver and
will launch the Xconfigurator. The color depth will have to be switched to 16
bit, or the nv driver specified to use 24 bit color. In order to center the
video output, the Generic 1280x1024 @ 76 Hz monitor will need to be selected
with the nv driver (the Monitor I have is a Proview 780, which doesn't have a
specific driver listed in the Xconfigurator).

Additional info:
Comment 1 Mike A. Harris 2002-10-08 18:06:58 EDT
XFree86 4.2.0 does not support GeForce 4.


For much much more detailed information, query closed bugzilla reports
for "geforce 4" in the description field against XFree86.

This is not a bug, but intentional that "vesa" is chosen.

When XFree86 4.3.0 is released, the default will be changed to "nv".

Note You need to log in before you can comment on or make changes to this bug.