Bug 754220 - Fontforge won't run
Summary: Fontforge won't run
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fontforge
Version: 16
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 772221 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-15 18:20 UTC by Dave P
Modified: 2012-01-06 16:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-17 13:33:18 UTC


Attachments (Terms of Use)

Description Dave P 2011-11-15 18:20:20 UTC
Description of problem:
Launch fontforge and it won't start up


Version-Release number of selected component (if applicable):
20110222

How reproducible:
$fontforge


Steps to Reproduce:
1.launch from cmd line
2.
3.
  
Actual results:
 fontforge
Copyright (c) 2000-2011 by George Williams.
 Executable based on sources from 13:48 GMT 22-Feb-2011.
 Library based on sources from 13:48 GMT 22-Feb-2011.
Help! Server claimed font
	-bitstream-bitstream charter-medium-r-normal--16-0-0-0-p-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
Segmentation fault



Expected results:
Font forge ran on FC15


Additional info:

Comment 1 Kevin Fenzi 2011-11-15 21:38:22 UTC
Looks like another case of: 
https://bugzilla.redhat.com/show_bug.cgi?id=450709
Perhaps this bug has re-appeared in f15->f16 upgrades?

Does: 

fc-cache /usr/share/X11/fonts/Type1

fix it?

Comment 2 Dave P 2011-11-16 05:34:22 UTC
Sorry, no.
Ran as ordinary user... you didn't say as root?


$ fc-cache /usr/share/X11/fonts/Type1
[dpawson@localhost ~]$ fontforge
Copyright (c) 2000-2011 by George Williams.
 Executable based on sources from 13:48 GMT 22-Feb-2011.
 Library based on sources from 13:48 GMT 22-Feb-2011.
Help! Server claimed font
	-bitstream-bitstream charter-medium-r-normal--16-0-0-0-p-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
Segmentation fault

Comment 3 Kevin Fenzi 2011-11-16 15:20:51 UTC
Sorry, I did mean run it as root. ;(

Comment 4 Dave P 2011-11-16 15:33:05 UTC
Ditto. 


# fc-cache /usr/share/X11/fonts/Type1
[root@localhost ~]# logout
[dpawson@localhost ~]$ fontforge
Copyright (c) 2000-2011 by George Williams.
 Executable based on sources from 13:48 GMT 22-Feb-2011.
 Library based on sources from 13:48 GMT 22-Feb-2011.
Help! Server claimed font
	-bitstream-bitstream charter-medium-r-normal--16-0-0-0-p-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
Segmentation fault


Dave

Comment 5 Paul Flo Williams 2011-11-16 16:29:48 UTC
From reading previous bugs around this area, I'm wondering whether there could be old fonts.dir files around the place which refer to font files that no longer exist, perhaps having disappeared in package upgrades. (We occasionally find that old packages ship fonts that they shouldn't.)

Dave, could you please try to identify where this "bitstream charter" font comes from, by running this:

$ egrep -r --include='fonts.dir' 'charter-medium-r.*iso10646' /usr/share | cut -d' ' -f1

Let's say you get this output:

/usr/share/X11/fonts/Type1/fonts.dir:c0648bt_.pfb
/usr/share/fonts/default/ghostscript/fonts.dir:bchr.pfa

I'd like to know whether the file after the colon exists in the directory before the colon. If it doesn't, we've got a problem.

Comment 6 Dave P 2011-11-16 16:35:32 UTC
Output from 
# egrep -r --include='fonts.dir' 'charter-medium-r.*iso10646' /usr/share | cut -d '' -f1
I hope I copied that correctly?


/usr/share/fonts/default/ghostscript/fonts.dir:bchr.pfa -bitstream-bitstream charter-medium-r-normal--0-0-0-0-p-0-iso10646-1

Dave

Comment 7 Paul Flo Williams 2011-11-16 22:39:24 UTC
And I'm guessing that /usr/share/fonts/default/ghostscript/bchr.pfa doesn't exist, right?

Bug 690593 removed Bitstream Charter from the ghostscript-fonts package because they were non-free. However, you appear to have fonts.dir that includes it (as do I, though I'm not seeing a crash because of it).

I think we still have a bug to do with the upgrading of ghostscript-fonts, though I can't see how. It isn't a FontForge bug; FontForge got lied to about which fonts exist.

Could you please try these commands to fix the font list that is being reported to FontForge? First, I'll explain them. We're going to move two erroneous files out of the way and regenerate them. If that fixes the problem, this bug can be moved to be against ghostscript-fonts.

Careful with the punctuation if you're not just cutting and pasting.

$ cd /usr/share/fonts/default/ghostscript
$ sudo mv fonts.scale{,.orig}
$ sudo mv fonts.dir{,.orig}
$ sudo mkfontscale
$ sudo mkfontdir

Then try FontForge again.

Comment 8 Dave P 2011-11-17 08:30:47 UTC
Thanks for spending time on this Paul.
Results below


[root@localhost ~]# cd /usr/share/fonts/default/ghostscript
[root@localhost ghostscript]# mv fonts.scale{,.orig}
[root@localhost ghostscript]# mv fonts.dir{,.orig}
[root@localhost ghostscript]# mkfontscale
[root@localhost ghostscript]# mkfontdir
[root@localhost ghostscript]# logout
[dpawson@localhost ~]$ fontforge
Copyright (c) 2000-2011 by George Williams.
 Executable based on sources from 13:48 GMT 22-Feb-2011.
 Library based on sources from 13:48 GMT 22-Feb-2011.
Help! Server claimed font
	-bitstream-bitstream charter-medium-r-normal--16-0-0-0-p-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
Segmentation fault


I see what you mean bout fontforge being lied to :-)

Dave

Comment 9 Dave P 2011-11-17 08:33:00 UTC
Sorry, I missed a bit.


$ ls /usr/share/fonts/default/ghostscript/
fcyr.afm   fhirw.gsf  fonts.dir         putbi.pfa  u003043t.afm  u004006t.gsf
fcyr.gsf   fhirw.pfm  fonts.dir.orig    putb.pfa   u003043t.gsf  u004006t.pfm
fcyri.afm  fkarw.gsf  fonts.scale       putri.pfa  u003043t.pfm
fcyri.gsf  fkarw.pfm  fonts.scale.orig  putr.pfa   u004006t.afm


So No

"And I'm guessing that /usr/share/fonts/default/ghostscript/bchr.pfa doesn't
exist, right?"
No, it doesn't exist.

Dave

Comment 10 Paul Flo Williams 2011-11-17 12:20:52 UTC
OK, we should now have a correct fonts.scale in that directory, which was used to make a correct fonts.dir. You can re-run the command from comment #6 to check that Charter is no longer *claimed* to be available, if you wish.

However, I'm not sure when fonts.dir files are read. It may only be at the startup of X, so I'd suggest that you reboot and then retry fontforge, please.

Comment 11 Dave P 2011-11-17 13:23:26 UTC
<grin/>
You can go to the top of the class Paul, 10/10.
Reboot, Fontforge now comes up happily!

Many thanks for your help.
Will you clear the bug or should I?
Does the changes you've suggested count it as being
cleared, or just that you know what to do to clear it?

Just need to find what's wrong with fontmatrix now.
Even odder?
Select it from the 'desktop' and it loads... but
only as an icon in the 'system tray' (that bit bottom right
of the screen?).

Dave

Comment 12 Paul Flo Williams 2011-11-17 13:33:18 UTC
Closing as not-a-bug in FontForge, because it never was, and Uncle George's ulcer gets inflamed whenever someone suggests it could be.

I'm not going to reassign this to ghostscript-fonts because, as far as I can see, the %post script does the right thing on first installation, and removing fonts between releases is a very rare thing, so we might never see this again. (Background action for me to resolve it, though.)

Comment 13 Kevin Fenzi 2012-01-06 16:51:11 UTC
*** Bug 772221 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.