Bug 754276 - clamav needs mimedefang subpackage
clamav needs mimedefang subpackage
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 17:43 EST by Philip Prindeville
Modified: 2012-01-25 15:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-25 15:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philip Prindeville 2011-11-15 17:43:57 EST
Description of problem:

There's a lot of trivial/mechanical work involved in setting up clamav to work with mimedefang. And it's easy to make a mistake and spend hours troubleshooting it (especially if SElinux is enabled).

A subpackage called "clamav-mimedefang" that installs and initializes the service would be handy.

Version-Release number of selected component (if applicable):

clamav-0.97.3-1500

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

It would contain:

/etc/clamd.d/mimedefang.conf
/etc/init.d/clamd.mimedefang
/etc/sysconfig/clamd.mimedefang
/usr/sbin/clamd.mimedefang

and during it's %postinst it would create:

/var/log/clamd.mimedefang
/var/run/clamd.mimedefang/

and run "chkconfig clamd.mimedefang on ; service clamd.mimedefang start".

It could also link:

ln -s /var/run/clamd.mimedefang/clamd.sock /var/spool/MIMEDefang/clamd.sock
Comment 1 Philip Prindeville 2011-11-16 20:55:47 EST
An interim set of proposed patches are here:

http://fedorapeople.org/~philipp/clamav-mimedefang.patch
Comment 2 Philip Prindeville 2011-12-31 21:11:34 EST
(In reply to comment #1)
> An interim set of proposed patches are here:
> 
> http://fedorapeople.org/~philipp/clamav-mimedefang.patch

Anyone?
Comment 3 Enrico Scholz 2012-01-25 15:21:49 EST
I am going to close this as WONTFIX because:

* 'clamav' is the wrong package for mimedefang/exim/... integration
  because these software projects have nothing in common except that
  they can communicate

* it will be a non trivial work (3 or 4 (with sysv) new subpackages,
  user creation, init script registration...)

* although I use mimedefang by myself, I am not familiar with exim or
  other server integration

* reassigning this bug to mimedefang/exim/... and requesting that the
  clamav integration is provided there is not a solution because items
  above hold for them too


Creating a new fedora package which does the requested integration
is probably the most clean solution. I do this for myself (see
http://ensc.de/clamd.mimedefang.spec) but do not have time to deal
with the fedora review process.

Note You need to log in before you can comment on or make changes to this bug.