Bug 75431 - Turning off anti-aliasing should turn off Xft
Turning off anti-aliasing should turn off Xft
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 10:37 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-09 14:29:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2002-10-08 10:37:54 EDT
Description of Problem:
Turning off anti-aliased fonts seems to only turn off hinting and not fall 
back to using the normal X font handling (non Xft). I think this isn't a 
good thing. Why? Because I for one hate antialiased fonts as it looks like 
everything is blurry and when I turn them off they look ugly as hell 
because Xft does not make a good job with no antialiased fonts.
Better yet, there should be a separate option associated with the one above 
mentioned to turn off Xft.

This applies to kde as well as gnome/gtk+-2 based apps.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 R.K.Aa. 2002-10-16 06:15:50 EDT
I couldn't agree more. After upgrading to RH8, all fonts suddenly look liks s***
here. I thought they were rendered by xfs, and actually i can't even start X if
xfs isn't running. But even if xlsfonts list all fonts neither KDE nor Gnome can
see my TT fonts, for instance.

They see them only after i add them to ~/.fonts and run fc-cache.

So instead of the crisp clear truetype fonts i used to have, i now seem to have
a choise between "fuzzy cottonball" or "barbed wired" look. Both outright ugly
compared to how things looked under RH7.2/7.3.

Is there any way to prevent Xft from being used in the first place?

Adding self to CC.
Comment 2 R.K.Aa. 2002-10-16 07:07:59 EDT
uh oh.. Is Xft perhaps the only way (apart from xtt) to render truetype fonts at
all on XFree86 4.2.0 ? Right now I am not loading "freetype" or any other font
modules from XF86Config - the only server running is xfs.
It used to be xfs with xfsft compiled in. Gnome2 snapshots from Ximian still
looked crisp clear while using the XFree86 that came with RH7.3.
But the RH8 version og Gnome2 has fonts with blurred edges - and if i choose not
to anti-alias them, they become even harder to read - "m" looks like "rn" etc.
How on earth do i get the good un-aliased font-rendering back? Please advice.
Comment 3 Carlos Rodrigues 2002-10-16 08:35:50 EDT
You can use TrueType fonts by adding them to a /usr/share/fonts/default
subdirectory (eg. /usr/share/fonts/default/TrueType)and running fc-cache (and
restarting xfs). You don't need to load freetype in XF86Config.
To get un-anti-aliased fonts which actually look good (without Xft) you have to
run qtconfig and disable antialiased font rendering in it for QT and define
"export GDK_USE_XFT=0" somewhere (like your ~/.bashrc) for GTK2 (there should be
a gtkconfig of some sort too).

PS: Since I think (I'm not actually a fundamentalist on this matter) that
antialiased fonts look better than non anti-aliased ones at some sizes (i.e.
really big or really small) I can only wish that Xft could at some point in the
future render un-antialiased fonts as well as the old font engine so that we
could have the best of both worlds.
Comment 4 R.K.Aa. 2002-10-16 09:12:57 EDT
To me, anti-aliasing fonts under Linux doesn't look good before the fonts are at
least 20px or more. AA'ing anything smaller and it looks blurred. I don't use
"cleartype" on XP either, and that implementation is much more mature than on
Linux. Basically.. antialiasing small fonts is as fun as sucking a wet sock. 
If you ask me. Which you didn't..

Anyways: cer09566@students.fct.unl.pt: you saved my day! :)
Comment 5 Roman Krylov 2004-03-05 10:24:36 EST
in 7.2 , 8.0 , fedora code I had & still have bad non-antialiased fonts
In 7.3 I haven't.
Every time I upgrade I have to replace distro's XFree86 with downloaded
from XFree86.org.
The problem,I think, is about xft+xrender.

Note You need to log in before you can comment on or make changes to this bug.