Bug 754358 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: amtu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
: 818946 (view as bug list)
Depends On:
Blocks: 751869 816135
  Show dependency treegraph
 
Reported: 2011-11-16 04:21 EST by Jóhann B. Guðmundsson
Modified: 2012-05-14 11:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: amtu-1.0.8-10.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 11:28:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd unit for amtu (231 bytes, text/plain)
2011-11-16 04:22 EST, Jóhann B. Guðmundsson
no flags Details
On failure poweroff unit (128 bytes, text/plain)
2011-11-16 04:22 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-11-16 04:21:39 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-11-16 04:22:18 EST
Created attachment 533937 [details]
Native systemd unit for amtu
Comment 2 Jóhann B. Guðmundsson 2011-11-16 04:22:52 EST
Created attachment 533939 [details]
On failure poweroff unit
Comment 3 Jóhann B. Guðmundsson 2011-11-16 04:26:26 EST
Note that I removed the network test from the unit since it always failed due to bug 682337 you can just add it back once it gets fixed

/etc/sysconfig/amtu has been dropped since user should just copy the amtu unit to /etc/systemd/system and edit there
Comment 4 Steve Grubb 2012-05-04 09:23:58 EDT
*** Bug 818946 has been marked as a duplicate of this bug. ***
Comment 5 Gwyn Ciesla 2012-05-11 10:58:35 EDT
Steve, any objection to my making this change?
Comment 6 Steve Grubb 2012-05-14 11:28:22 EDT
The init script has now been removed. Amtu is on a path towards deprecation. We should not waste any time on it.
Comment 7 Gwyn Ciesla 2012-05-14 11:35:03 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.