Bug 75436 - Only lets me select scalable fonts
Only lets me select scalable fonts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 11:49 EDT by Eric Hopper
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 11:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Hopper 2002-10-08 11:49:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I want to use fonts in the schumacher foundry, under the family 'clean'.  The
font selector is very limited and appears to only allow selection of scalable
fonts via 'english' names.  gnome-terminal's usefulness to me is severely
curtailed with this restriction.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Right click gnome-terminal
2.Click on the font name


Actual Results:  I got an anemic font selection dialog box that won't let me
select any -schumache-clean fonts.

Expected Results:  A nice, fully featured font selection dialog box like the one
in gnome-terminal from gnome 1.


Additional info:

I know these fonts will not be able to be rendered anti-aliased.  I like very
tiny type sizes, and these fonts are very carefully designed to look good even
when they are only 6 pixels wide.  They also have 0's that have /'s through
them, which I consider absolutely essential for technical work, especially at
tiny type sizes.

I would also like to know what the X font selector is for any selected font.  I
would also like to be able to filter fonts using the X font selector field.

In short, I want the font selection dialog to be as fully featured as the one
for gnome 1.  I consider it a bug that the dialog from a later version doesn't
have the features or flexibility that a dialog from a previous version had.
Comment 1 Havoc Pennington 2002-10-08 12:21:31 EDT
The problem is that you do not have those fonts configured to be available to
the new fontconfig/Xft2 font system.

The old font backend for X is deprecated, no GTK 2 or Qt 3 applications
are using it. The old-style -*-*-*- etc. font names are no longer used at any layer.

If you want to use the Schumacher fonts you need to move those fonts to 
/usr/share/fonts or ~/.fonts, and be sure they are uncompressed (not gzip'd).
Then they will show up in the new fontconfig/Xft2 applications.
Comment 2 Eric Hopper 2002-10-08 12:37:20 EDT
Is there a README on this procedure somewhere?  I've tried what you've simply
outlined there, and it didn't work.  How do you get the fonts.cache-1 file updated?

It looks like it's a much better system.  I'm not sure how you could've
documented it better.
Comment 3 Havoc Pennington 2002-10-08 14:07:04 EDT
font cache should auto-update for ~/.fonts, for /usr/share/fonts 
you may need to run "fc-cache"

It could certainly use better docs, there may be some discussion in the release
notes. Be sure you restart the terminal (this means all open terminal windows
need to close, or start a new terminal with "gnome-terminal --disable-factory"), 
and be sure the fonts are not compressed (i.e. gunzip them).
Comment 4 Eric Hopper 2002-10-08 14:21:19 EDT
It doesn't update, even after I run fc-cache.  Testing has led me to conclude
that for some reason, fc-cache is insistent on ignoring the uncompressed .pcf
files for the -schumacher-clean family. It doesn't ignore the .pcf files for the
LucididaTypewriter family, so I know fc-cache is updating the directory I'm
putting the -schmuacher-clean files in.  Anyway, I filed another bug in
fontconfig for this problem.  :-)

Thanks for your help.
Comment 5 Eric Hopper 2002-10-08 14:22:21 EDT
The fontconfig bug:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75444

Note You need to log in before you can comment on or make changes to this bug.