Bug 754382 - Login after session timeout does not (re)display the portlets on summary tab
Login after session timeout does not (re)display the portlets on summary tab
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.0.0
Unspecified Unspecified
medium Severity medium
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon30-sprint9
  Show dependency treegraph
 
Reported: 2011-11-16 05:28 EST by Heiko W. Rupp
Modified: 2014-01-02 15:39 EST (History)
5 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot directly after login (after timed out session) (28.13 KB, image/png)
2011-11-16 05:28 EST, Heiko W. Rupp
no flags Details

  None (edit)
Description Heiko W. Rupp 2011-11-16 05:28:17 EST
Created attachment 533961 [details]
Screenshot directly after login (after timed out session)

Go to e.g. the CPUs autogroup, summary tab. have it display metrics  (after the patch from BUG  ) and then
do something else until the session times out.
Then log in again.
See that the metrics are no longer shown and the alerts portlet shows the spinning circle

Got to inventory tab and back to summary to see the metrics again.

Looks like after login we need to send a refresh to the whole page
Comment 1 Heiko W. Rupp 2011-11-16 06:36:30 EST
This also applies to single resources and the summary tab.
Comment 2 Jay Shaughnessy 2011-11-17 09:23:49 EST
I think I know where to fix this. I'll take a stab at it.
Comment 3 Jay Shaughnessy 2011-11-17 16:15:18 EST
I believe this is now working as desired.

master     commit dae9b5cc5568a1d76d56a458d0973b4fd8ac6d5d
release3.x commit 9a7e2047d3d6c7bffb85afb70dc41a98691ba6c9

    A couple of things going on here:
    - make sure we request a refresh after re-login, for RefreshableViews
    - make the dashboard views Refreshable to take advantage of the above
      change
    - for the global dash, ensure switching amongst dash tabs works
      appropriately

Test Notes:
A little difficult for testing in that it takes an hour for us to timeout
a session.  Doable although tedious.  Anyone wanting to test this using
a dev build can lower SESSION_TIMEOUT in UserSessionManager to be much
lower, like a minute.
Comment 4 Robert Buck 2011-11-23 19:55:49 EST
FAIL - I tested this against master and after a session timeout and re-login I see the spinner. If I go to a different page and come back all the metrics reload. This sounds like the same behavior that Heiko reported, so I don't think this has been fixed; please confirm with Heiko.
Comment 5 Heiko W. Rupp 2011-11-24 10:08:09 EST
works for me with on Safari, but fails on FF8 

And yes, I know that both are not supported.
Comment 6 Robert Buck 2011-11-28 08:39:23 EST
(In reply to comment #4)
> FAIL - I tested this against master and after a session timeout and re-login I
> see the spinner. If I go to a different page and come back all the metrics
> reload. This sounds like the same behavior that Heiko reported, so I don't
> think this has been fixed; please confirm with Heiko.

n.b. I tested with FF8; I didn't have an old version of FF.
Comment 8 Jay Shaughnessy 2012-02-10 10:30:33 EST
Moving this to ON_QA to test in a supported browser.
Comment 9 Larry O'Leary 2013-09-06 10:32:19 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 10 Jeeva Kandasamy 2013-11-19 06:29:49 EST
Version:
JBOSS Operations Network
Version : 3.2.0.ER5
Build Number : 2cb2bc9:225c796
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox ESR 17.0.7
OS: RHEL 6.4 (x64)

Page gets refreshed once logged in after session timeout.

Note You need to log in before you can comment on or make changes to this bug.