Bug 754407 - Yawp doesn't obey geometry settings.
Yawp doesn't obey geometry settings.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-yawp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 07:05 EST by Martin Kho
Modified: 2011-12-14 18:34 EST (History)
3 users (show)

See Also:
Fixed In Version: kde-plasma-yawp-0.4.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-14 18:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2011-11-16 07:05:32 EST
Description of problem:
The yawp applet show up with it's initial size after log in, though a different geometry was set at previous log out.

Version-Release number of selected component (if applicable):
kde-plasma-yawp-0.4.0-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. put the applet on the desktop
2. resize the applet
3. log out / log in -> yawp has it's original size
  
Actual results:
yawp returns to it's initial size

Expected results:
yawp keeps the custom size

Additional info:
Info from plasma-desktop-appletsrc:

1. Initial geometry:
[Containments][8][Applets][62]
geometry=438,0,273,255
immutability=1
plugin=yaWP
zvalue=47

2. Custom geometry:
[Containments][8][Applets][62]
geometry=438,0,316.463562491939,295.597833096866
immutability=1
plugin=yaWP
zvalue=49
Comment 1 Orcan Ogetbil 2011-11-16 08:02:42 EST
Hi, is this problem specific to yawp, or does it apply to other plasmoids?
Comment 2 Martin Kho 2011-11-16 08:14:59 EST
Hi, Ocran,

Yes it's specific to yawp version 0.4. The previous version (0.3.6) and all other applets (I'm using cpu-monitor, temp monitor, fileview and network monitor) are behaving okay.

Martin Kho
Comment 3 Musikolo 2011-11-16 14:17:01 EST
Hi,

I'm also having the very same problem in my laptop (i686) and my desktop PC (x86_64) both having Arch Linux.

I hope you find a quick solution to this annoying bug.

Best regards and good work.
Comment 4 Fedora Update System 2011-11-16 14:26:53 EST
kde-plasma-yawp-0.4.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-15898
Comment 5 Fedora Update System 2011-11-16 14:27:49 EST
kde-plasma-yawp-0.4.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2011-15902
Comment 6 Musikolo 2011-11-16 14:42:24 EST
Hi guys,

One more thing, would it  be possible to have access to the patch that fixes this bug, when possible?

Best regards.
Comment 8 Martin Kho 2011-11-17 03:32:10 EST
Hi, nucleo,

I've tried both the fc17 (from koji) and fc16 version (from comment 4), but there is still something wrong. Resizing does have an effect, but after log out/log in the applet is smaller than set.

On fc17 it looks like that there is another issue now. After the resize, the applet sometimes returns to it's previous size. For now I'm not sure how to reproduce, so I'll let you know as soon as I have more info.

Thanks and sorry,


Martin Kho
Comment 9 Musikolo 2011-11-17 16:43:57 EST
Hi guys,

I agree with Martin, the same issue is happening to me. The patch has improved the previous situation, but it hasn't solved it fully.

I hope a definitive solution can be found soon.

Thanks for your time and effort, great piece of software!

Regards.
Comment 10 nucleo 2011-11-17 16:46:29 EST
I will update patch soon.
Comment 11 Fedora Update System 2011-11-17 18:31:43 EST
Package kde-plasma-yawp-0.4.0-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-yawp-0.4.0-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15902/kde-plasma-yawp-0.4.0-4.fc15
then log in and leave karma (feedback).
Comment 12 Martin Kho 2011-11-18 07:09:44 EST
Hi nucleo,

Congratulations, for me version 0.4.0-5 (from koji) is working in Fedora 17.

Thanks,

Martin Kho
Comment 13 Musikolo 2011-11-18 15:19:49 EST
Can we have access to the new patch? When is it gonna be released a new (patched) version?

Regards.
Comment 14 nucleo 2011-11-18 19:22:36 EST
Patch is there http://pkgs.fedoraproject.org/gitweb/?p=kde-plasma-yawp.git;a=blob_plain;f=kde-plasma-yawp-fix-geometry.patch

0.4.0-5 tomorrow will be pushed to F15 and F16 updates-testing.
Comment 15 Musikolo 2011-11-19 04:34:12 EST
@Nucleo:

Congrats, I have tried the new patch in my two PCs (i686 laptop and x86_64 desktop) and it's working seamlessly in both.

Thank you very much for your support.

Best regards.
Comment 16 Martin Kho 2011-11-21 16:07:23 EST
Hi,

This report can be closed I suppose. Version -5 is working on F16 and F17 for me.


Thanks,


Martin Kho
Comment 17 nucleo 2011-11-21 16:12:38 EST
This bug will be closed when update will be pushed to stable.
But I prefer to wait 0.4.1 release because better fixes will be there for this bug and for other issues.
Comment 18 Martin Kho 2011-11-21 16:21:08 EST
Hi nucleo,

Thanks for the info. I'll be patient :-)

Martin Kho
Comment 19 nucleo 2011-12-05 13:55:07 EST
kde-plasma-yawp-0.4.1 is in F15 and F16 updates testing.
Please, test it.
Comment 20 Martin Kho 2011-12-05 16:19:31 EST
Hi nucleo,

In Fedora 17 (rawhide) it works perfect. I'll try it later in fc16.

Thanks,

Martin Kho
Comment 21 Martin Kho 2011-12-07 04:09:05 EST
Hi nucleo,

Updated yawp in Fedora 16 and ever thing seems fine.

Thanks,

Martin Kho
Comment 22 Fedora Update System 2011-12-14 18:31:25 EST
kde-plasma-yawp-0.4.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2011-12-14 18:34:33 EST
kde-plasma-yawp-0.4.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.