Bug 754418 - Provide native systemd service
Summary: Provide native systemd service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: autodir
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 751869
TreeView+ depends on / blocked
 
Reported: 2011-11-16 12:48 UTC by Jóhann B. Guðmundsson
Modified: 2012-05-31 15:19 UTC (History)
3 users (show)

Fixed In Version: autodir-0.99.9-12.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-16 21:24:25 UTC


Attachments (Terms of Use)
Native systemd unit for autogroup (359 bytes, text/plain)
2011-11-16 12:49 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd unit for autohome (312 bytes, text/plain)
2011-11-16 12:49 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-11-16 12:48:39 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-11-16 12:49:25 UTC
Created attachment 534008 [details]
Native systemd unit for autogroup

Comment 2 Jóhann B. Guðmundsson 2011-11-16 12:49:55 UTC
Created attachment 534009 [details]
Native systemd unit for autohome

Comment 3 Gwyn Ciesla 2012-02-14 16:37:55 UTC
Mattias, any objection to my making this change?

Comment 4 Fedora Update System 2012-03-09 19:02:50 UTC
autodir-0.99.9-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/autodir-0.99.9-12.fc17

Comment 5 Fedora Update System 2012-03-10 01:23:36 UTC
Package autodir-0.99.9-12.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autodir-0.99.9-12.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3510/autodir-0.99.9-12.fc17
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-03-16 21:24:25 UTC
autodir-0.99.9-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Rick Foos 2012-05-31 15:19:57 UTC
Using autohome on fc16. After preupgrade, autohome is disabled, and can't be started as a service anymore. 

(Since it wasn't a service, autohome.target took a while to figure out, and would be nice if that was taken care of by preupgrade...nuisance?)

1. If autohome/autogroup was enabled, preupgrade should:
systemctl enable autohome.target

2. /etc/sysconfig/autohome appears to be deprecated, or needs to be integrated with autohome.target. 
- I don't see any way to pass the backup options in /etc/sysconfig/autohome anywhere else.
- I don't see any way to pass the permissions and directory options from /etc/sysconfig/autohome to override the hardcoded options in autohome.target.


Note You need to log in before you can comment on or make changes to this bug.