Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 754423 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: arptables_jf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
: 820128 (view as bug list)
Depends On:
Blocks: 751869
  Show dependency treegraph
 
Reported: 2011-11-16 08:02 EST by Jóhann B. Guðmundsson
Modified: 2012-05-18 10:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 11:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2011-11-16 08:02:16 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2012-03-29 05:12:33 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Gwyn Ciesla 2012-05-11 11:05:19 EDT
Jiri, any objections to my making this change?
Comment 3 Jiri Popelka 2012-05-11 11:21:56 EDT
(In reply to comment #2)
> Jiri, any objections to my making this change?

Not a bit, go ahead. Thank you !
Comment 4 Gwyn Ciesla 2012-05-11 12:15:37 EDT
I'm nearly done, but I'm not sure how the /etc/sysconfig/arptables is created.
Comment 5 Jiri Popelka 2012-05-11 13:17:02 EDT
Me neither (I took over this package few weeks ago). Seems that it's not created at all. I'm not sure whether it's a bug or not.
Comment 6 Gwyn Ciesla 2012-05-11 13:25:00 EDT
Well, the initscript won't start without it, and the man pages don't say much, and google doesn't either.  Is it possible to contact the old maintainer?
Comment 7 Jiri Popelka 2012-05-14 08:30:43 EDT
jskala is still in CC ;-)

Anyway, I haven't found any related info in packaging guidelines so I suggest
we create and install empty /etc/sysconfig/arptables.

What do you think, Jon ?
Comment 8 Gwyn Ciesla 2012-05-14 10:41:41 EDT
My only reservation is that the service will still fail to start after a new installation.  I'd like to document how to make a usable file, but then I suppose if that's not provided now, we're just taking a moderately broken situation under one init system and replicating it in another. :)  Would you have anything to contribute to that end, or should I just create the sysconfig file and ship it all as is?
Comment 9 Jiri Popelka 2012-05-14 10:57:10 EDT
(In reply to comment #8)
> My only reservation is that the service will still fail to start after a new
> installation.

I don't see a problem here. That's how for example dhcp works too, i.e. dhcpd service also fails to start unless user puts some meaningful configuration into /etc/dhcp/dhcpd.conf (which is empty by default).

> Would you have anything to contribute to that end, or should I
> just create the sysconfig file and ship it all as is?

I have nothing to add. Go ahead please. Thank you!
Comment 10 Gwyn Ciesla 2012-05-14 11:59:04 EDT
Done, thanks!
Comment 11 Jiri Popelka 2012-05-14 12:13:29 EDT
*** Bug 820128 has been marked as a duplicate of this bug. ***
Comment 12 Jiri Popelka 2012-05-16 13:47:00 EDT
Jon, there's been a problem in the arptables-helper script.
When I started the service it failed and system log contained:
arptables-helper[5829]: /sbin/arptables-helper: line 130: syntax error near unexpected token `2'

I fixed it in
http://pkgs.fedoraproject.org/gitweb/?p=arptables_jf.git;a=commitdiff;h=75ccb447e3358a521aee8ee35ab2f2a933e9ecbe
can you check if it's ok ?
Comment 13 Gwyn Ciesla 2012-05-16 13:49:19 EDT
Looks good to me, I hit that when I first made it and apparently committed the one I hadn't fixed.  Thanks, good catch.  Sorry for the misfingering.
Comment 14 Jiri Popelka 2012-05-18 10:53:38 EDT
I've moved the arptables-helper script from /sbin/ to /usr/libexec/
because it won't be started directly by user and also that's where iptables package installs similar script.
http://pkgs.fedoraproject.org/gitweb/?p=arptables_jf.git;a=commitdiff;h=2d240e8872d2c12265db61d34516c927609c5666

Note You need to log in before you can comment on or make changes to this bug.