Bug 754423 - Provide native systemd service
Summary: Provide native systemd service
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: arptables_jf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 820128 (view as bug list)
Depends On:
Blocks: 751869
TreeView+ depends on / blocked
 
Reported: 2011-11-16 13:02 UTC by Jóhann B. Guðmundsson
Modified: 2012-05-18 14:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-14 15:59:04 UTC


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2011-11-16 13:02:16 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fedora Admin XMLRPC Client 2012-03-29 09:12:33 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Gwyn Ciesla 2012-05-11 15:05:19 UTC
Jiri, any objections to my making this change?

Comment 3 Jiri Popelka 2012-05-11 15:21:56 UTC
(In reply to comment #2)
> Jiri, any objections to my making this change?

Not a bit, go ahead. Thank you !

Comment 4 Gwyn Ciesla 2012-05-11 16:15:37 UTC
I'm nearly done, but I'm not sure how the /etc/sysconfig/arptables is created.

Comment 5 Jiri Popelka 2012-05-11 17:17:02 UTC
Me neither (I took over this package few weeks ago). Seems that it's not created at all. I'm not sure whether it's a bug or not.

Comment 6 Gwyn Ciesla 2012-05-11 17:25:00 UTC
Well, the initscript won't start without it, and the man pages don't say much, and google doesn't either.  Is it possible to contact the old maintainer?

Comment 7 Jiri Popelka 2012-05-14 12:30:43 UTC
jskala is still in CC ;-)

Anyway, I haven't found any related info in packaging guidelines so I suggest
we create and install empty /etc/sysconfig/arptables.

What do you think, Jon ?

Comment 8 Gwyn Ciesla 2012-05-14 14:41:41 UTC
My only reservation is that the service will still fail to start after a new installation.  I'd like to document how to make a usable file, but then I suppose if that's not provided now, we're just taking a moderately broken situation under one init system and replicating it in another. :)  Would you have anything to contribute to that end, or should I just create the sysconfig file and ship it all as is?

Comment 9 Jiri Popelka 2012-05-14 14:57:10 UTC
(In reply to comment #8)
> My only reservation is that the service will still fail to start after a new
> installation.

I don't see a problem here. That's how for example dhcp works too, i.e. dhcpd service also fails to start unless user puts some meaningful configuration into /etc/dhcp/dhcpd.conf (which is empty by default).

> Would you have anything to contribute to that end, or should I
> just create the sysconfig file and ship it all as is?

I have nothing to add. Go ahead please. Thank you!

Comment 10 Gwyn Ciesla 2012-05-14 15:59:04 UTC
Done, thanks!

Comment 11 Jiri Popelka 2012-05-14 16:13:29 UTC
*** Bug 820128 has been marked as a duplicate of this bug. ***

Comment 12 Jiri Popelka 2012-05-16 17:47:00 UTC
Jon, there's been a problem in the arptables-helper script.
When I started the service it failed and system log contained:
arptables-helper[5829]: /sbin/arptables-helper: line 130: syntax error near unexpected token `2'

I fixed it in
http://pkgs.fedoraproject.org/gitweb/?p=arptables_jf.git;a=commitdiff;h=75ccb447e3358a521aee8ee35ab2f2a933e9ecbe
can you check if it's ok ?

Comment 13 Gwyn Ciesla 2012-05-16 17:49:19 UTC
Looks good to me, I hit that when I first made it and apparently committed the one I hadn't fixed.  Thanks, good catch.  Sorry for the misfingering.

Comment 14 Jiri Popelka 2012-05-18 14:53:38 UTC
I've moved the arptables-helper script from /sbin/ to /usr/libexec/
because it won't be started directly by user and also that's where iptables package installs similar script.
http://pkgs.fedoraproject.org/gitweb/?p=arptables_jf.git;a=commitdiff;h=2d240e8872d2c12265db61d34516c927609c5666


Note You need to log in before you can comment on or make changes to this bug.