Bug 754481 - Wifi signal losses every 30-45mn with RT3090
Summary: Wifi signal losses every 30-45mn with RT3090
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-16 16:19 UTC by Dan
Modified: 2012-07-12 09:42 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-07-12 09:42:51 UTC


Attachments (Terms of Use)
RPM from RussianFedora (17.21 KB, application/x-rpm)
2011-11-27 11:31 UTC, tuxor
no flags Details
kmod-RPM from RussianFedora (8.85 KB, application/x-rpm)
2011-11-27 11:32 UTC, tuxor
no flags Details
Second kmod-RPM from RussianFedora (341.94 KB, application/x-rpm)
2011-11-27 11:33 UTC, tuxor
no flags Details
akmod-RPM from RussianFedora (954.56 KB, application/x-rpm)
2011-11-27 11:33 UTC, tuxor
no flags Details

Description Dan 2011-11-16 16:19:28 UTC
Description of problem:

I am currently encountering a bug on my laptop, which is a french HP DM1-3100 (also known in its international version as the DM1Z).
My WLAN chipset is a rt3090, and it's a fresh F16 install with no special repo, so standard 3.1 kernel.
At times (every 30-45minutes) I lose WLAN for 10 seconds approximately. I see a "Disconnected" notification, and it automatically retries and succeeds to reconnect, which is particularly annoying if a stable connection is required (file downloads, streaming, games I guess, etc...) and for the user experience in general. Can anyone else confirm that bug?
This bug might not belong in kernel, feel free to move it elsewhere.

Version-Release number of selected component (if applicable):

F16 fresh install with no extra repository.

How reproducible:


Steps to Reproduce:
1.Connect to a Wifi network
2.Do some surfing/streaming
3.Keep an eye on your network-manager applet.
  
Actual results:

Wifi losses

Expected results:

Stable Wifi

Additional info:

Comment 1 tuxor 2011-11-27 00:33:42 UTC
Do you connect to wpa hotspots?

Using the same wifi chip (rt3090), this laptop here most of the time doesn't want to connect, but repeatedly asks for the WPA key:

http://forums.fedoraforum.org/showthread.php?t=273086

Sometimes a connection is successfully established by NetworkManager, but that's only sporadic.

The rt3090 seems to be handled by these modules:

$ lsmod | grep rt2
rt2800pci               9507  0
rt2800lib              39527  1 rt2800pci
crc_ccitt               1557  1 rt2800lib
rt2x00pci               5768  1 rt2800pci
rt2x00lib              46254  3 rt2800pci,rt2800lib,rt2x00pci
mac80211              251806  3 rt2800lib,rt2x00pci,rt2x00lib
cfg80211              151125  2 rt2x00lib,mac80211
eeprom_93cx6            1647  1 rt2800pci

Maybe somebody could tell, which log files to look at and what to test in order to find the reason for this strange behaviour.

Comment 2 Dan 2011-11-27 11:27:06 UTC
(In reply to comment #1)
> Do you connect to wpa hotspots?
> 
> Using the same wifi chip (rt3090), this laptop here most of the time doesn't
> want to connect, but repeatedly asks for the WPA key:
> 
> http://forums.fedoraforum.org/showthread.php?t=273086
> 
> Sometimes a connection is successfully established by NetworkManager, but
> that's only sporadic.
> 
> The rt3090 seems to be handled by these modules:
> 
> $ lsmod | grep rt2
> rt2800pci               9507  0
> rt2800lib              39527  1 rt2800pci
> crc_ccitt               1557  1 rt2800lib
> rt2x00pci               5768  1 rt2800pci
> rt2x00lib              46254  3 rt2800pci,rt2800lib,rt2x00pci
> mac80211              251806  3 rt2800lib,rt2x00pci,rt2x00lib
> cfg80211              151125  2 rt2x00lib,mac80211
> eeprom_93cx6            1647  1 rt2800pci
> 
> Maybe somebody could tell, which log files to look at and what to test in order
> to find the reason for this strange behaviour.

Yes, these are WPA networks. Need additional info?

Comment 3 tuxor 2011-11-27 11:31:42 UTC
Created attachment 537054 [details]
RPM from RussianFedora

This is where this RPM comes from:
http://koji.russianfedora.ru/koji/buildinfo?buildID=73

Comment 4 tuxor 2011-11-27 11:32:33 UTC
Created attachment 537055 [details]
kmod-RPM from RussianFedora

This one is from: http://koji.russianfedora.ru/koji/buildinfo?buildID=750 (built on my machine against the latest kernel)

Comment 5 tuxor 2011-11-27 11:33:06 UTC
Created attachment 537056 [details]
Second kmod-RPM from RussianFedora

This one is from: http://koji.russianfedora.ru/koji/buildinfo?buildID=750 (built on my machine against the latest kernel)

Comment 6 tuxor 2011-11-27 11:33:34 UTC
Created attachment 537057 [details]
akmod-RPM from RussianFedora

This one is from: http://koji.russianfedora.ru/koji/buildinfo?buildID=750 (built on my machine against the latest kernel)

Comment 7 tuxor 2011-11-27 11:35:27 UTC
The above attachments (four RPMs) provide an alternative driver for RT3090 chipset. Feel free to test those on your 64bit-machine.

Comment 8 Dan 2011-11-27 12:22:03 UTC
(In reply to comment #7)
> The above attachments (four RPMs) provide an alternative driver for RT3090
> chipset. Feel free to test those on your 64bit-machine.

What shall I install? akmod is enough, right? Plus it will prevent me from having to run a kmod rebuild on every kernel update.
In addition to that, will I have to disable some kernel modules to avoid conflicts?

Comment 9 tuxor 2011-11-27 12:34:58 UTC
You will have to install all 4 of them (don't know why they splitted this into 4 rpms in RussianFedora).

You should first try it without blacklisting any other kernel moduls. Reboot and get the output of "lsmod | grep rt2", "lspci -k" and "iwconfig".

It _might_ conflict with these modules:

rt2800pci
rt2800lib
rt2x00pci
rt2x00lib

It shouldn't do that, but if it does, try blacklisting them in /etc/modprobe.d/blacklist.conf and reboot. Then check again with "lspci -k" and "iwconfig".

Comment 10 tuxor 2011-11-27 12:43:45 UTC
Maybe it even works without those kmod*-packages, but you will need at least both the rt3090- and the akmod-package.

And if loading rt3090 and blacklisting those rt28*-modules lets your wlan-device vanish from "iwconfig": remember that you can simply uninstall the rpms and unblacklist all the rt28* modules. This will bring you back to the initial state. 

If that is the case, we will have to look for a different solution.

By the way, I suspect, "64bit" is the problem. In FedoraForum I talked to two people who's rt3090 worked brilliantly on i686 installations. So in the end, a final solution could be found in those rt28** modules - but I'm not in to that.

Comment 11 tuxor 2011-11-27 16:35:52 UTC
So, this is how the new driver works:

# yum -y install kmod-rt3090-3.1.2-1.fc16.x86_64-2.4.0.4-3.fc16.8.R.x86_64.rpm rt3090-2.4.0.4-1.fc16.noarch.rpm

# echo "blacklist rt2800pci" >> /etc/modprobe.d/blacklist.conf

After a reboot, your wifi connections should work properly, and you will get:

$  lsmod | grep rt2
$  lsmod | grep rt3
rt3090sta             816145  1

$ lspci -k
(...)
43:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe
        Subsystem: Hewlett-Packard Company Device 1453
        Kernel driver in use: rt2860
        Kernel modules: rt3090sta, rt2800pci
(...)

So your new driver will be called "rt2860", even though the module's name is "rt3090sta". Please report back, if it works for you.

Comment 12 Stanislaw Gruszka 2011-12-22 17:08:27 UTC
We have to make in kernel driver work ...

Comment 13 Stanislaw Gruszka 2012-02-26 12:12:28 UTC
There are some pending radio chip programming fixes which should address this issue on rt2x00, you can try compat-wirless-next packages from  http://people.redhat.com/sgruszka/compat_wireless.html to see if this fix the problem.

Comment 14 Dave Jones 2012-03-22 16:50:30 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 15 Dave Jones 2012-03-22 16:54:46 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 16 Dave Jones 2012-03-22 17:05:28 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 17 Stanislaw Gruszka 2012-03-22 20:03:19 UTC
This will be fixed in 3.4 release, I'm going to backport proper rt2x00 changes to 3.3.

Comment 18 Stanislaw Gruszka 2012-05-15 11:07:49 UTC
Actually no, I will rather wait since fedora will start using 3.4 kernel

Comment 19 Josh Boyer 2012-05-15 12:21:05 UTC
I'll put this in POST state so it's easier to spot when we rebase to 3.4.  Should be relatively soon, as 3.4-rc7 is supposed to be the last rc before the final 3.4 release.

Comment 20 tuxor 2012-05-15 17:24:26 UTC
Are we going to have kernel 3.4 for Fedora 16 and 17 or do we have to wait for FC18?

Comment 21 Josh Boyer 2012-05-15 17:37:30 UTC
(In reply to comment #20)
> Are we going to have kernel 3.4 for Fedora 16 and 17 or do we have to wait for
> FC18?

Yes.  F16 and F17 will be rebased around the time 3.4.1 is released.

Comment 22 Stanislaw Gruszka 2012-07-12 09:42:51 UTC
We already have kernel 3.4 on F-16 and F-17. I'm closing this bug, if issue still happen please reopen it.


Note You need to log in before you can comment on or make changes to this bug.