Bug 754498 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bip (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 751869
  Show dependency treegraph
 
Reported: 2011-11-16 12:17 EST by Jóhann B. Guðmundsson
Modified: 2012-04-18 15:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:38:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd unit for bip (209 bytes, text/plain)
2011-11-16 12:17 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit for bip (197 bytes, text/plain)
2011-11-16 12:19 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-11-16 12:17:03 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-11-16 12:17:33 EST
Created attachment 534058 [details]
Native systemd unit for bip
Comment 2 Jóhann B. Guðmundsson 2011-11-16 12:19:07 EST
Created attachment 534059 [details]
Native systemd unit for bip

New unit with correct description
Comment 3 Jóhann B. Guðmundsson 2011-11-16 12:23:28 EST
Note that you need to update the config file to point to the correct PIDFile path as  "/run/bip/bip.pid" and you probably need to contact upstream because there something seriously messed up with the daemon since it's adding the hostname and the PID behind the actually bip.pid file...

Nov 16 17:10:54 valhalla bip[24747]: 16-11-2011 17:10:54 FATAL: Cannot write to PID file (/run/bip/bip.pid.valhalla.rhi.hi.is.24747 <--- ???) No such file or directory
Comment 4 Brian Lane 2011-11-16 12:26:06 EST
Thanks!
Comment 5 Gwyn Ciesla 2012-04-18 15:38:52 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.