Bug 75452 - Metacity sometimes has layer-like behavior
Metacity sometimes has layer-like behavior
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 14:35 EDT by Yaron Minsky
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 17:33:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaron Minsky 2002-10-08 14:35:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Sometimes (I don't know what triggers it), Metacity starts behaving as if it
supports layers.  In particular, all new windows appear behind other windows and
can't be brought to the fore.  This despite the fact that metacity does not
present any control of the layer structure.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
I don't know how to reproduce, it just occasionally happens.  I'm keeping my
eyes out, though.
	

Additional info:
Comment 1 Havoc Pennington 2002-10-08 14:51:05 EDT
I'm going to need more specifics to do anything with this. Which windows are
involved, exactly what was expected and what happened and can I reproduce it.

The stacking order stuff is rearranged/redone a bit in CVS, so it may already be
addressed.
Comment 2 Yaron Minsky 2002-10-08 15:41:40 EDT
Sorry, I can't reproduce it myself --- it just occasionally happens to me.  It
does seem to be connected to the fullscreen/maximize behavior, since I've
noticed it happening more than once on fullscreened windows.  I've seen this on
gnome-terminal and xemacs windows.
Comment 3 Havoc Pennington 2002-10-08 16:50:38 EDT
fullscreen windows are in a top layer, yes, but that's deliberate. 
Can you please be more specific about the layer-like behavior you aren't
expecting, or what goes wrong with it.
Comment 4 Yaron Minsky 2002-10-08 17:59:44 EDT
Sorry, I wasn't sufficiently clear.  I understand that fullscreen windows are on
a top layer.  But that's not the problem I'm talking about.  What I found is
that sometimes, all new windows would seem to be stuck in a layer below all
existing windows.  (Note that this state didn't last forever, but I didn't see
any particular trigger for it ending.  And there were multiple windows in the
top layer, so I don't think that a window which had been full-screened somehow
just got stuck in the toplayer)  This was the case even when no windows were
maximized or full-screened.

I'm aware this probably isn't enough information.  But I thought it might be a
useful starting point, and I'll add more specific info if/when I figure out the
trigger.

By the way, I'd actually kind of like it if it was possible to have a window
above a full-screened window.  I fullscreen a window because I want more screen
real-estate, not because I want it to be in the foreground forever.  But that's
an issue unrelated to the bug.
Comment 5 Havoc Pennington 2003-01-12 17:33:49 EST
Reopen if you can figure out a recipe to reproduce. (or go ahead and file the
recipe on bugzilla.gnome.org directly)

Note You need to log in before you can comment on or make changes to this bug.