Bug 754568 - [abrt] gnome-shell-3.2.1-6.fc17: _int_free: Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
[abrt] gnome-shell-3.2.1-6.fc17: _int_free: Process /usr/bin/gnome-shell was ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
abrt_hash:e25f7c20f80bf7373080798fed8...
: CommonBugs
: 802013 (view as bug list)
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2011-11-16 16:03 EST by Adam Williamson
Modified: 2014-06-18 05:14 EDT (History)
23 users (show)

See Also:
Fixed In Version: xorg-x11-drv-qxl-0.0.22-0.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 15:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (20.77 KB, text/plain)
2011-11-16 16:03 EST, Adam Williamson
no flags Details
File: build_ids (6.85 KB, text/plain)
2011-11-16 16:03 EST, Adam Williamson
no flags Details
File: var_log_messages (2.68 KB, text/plain)
2011-11-16 16:03 EST, Adam Williamson
no flags Details
File: maps (80.34 KB, text/plain)
2011-11-16 16:03 EST, Adam Williamson
no flags Details
File: backtrace (81.54 KB, text/plain)
2011-11-16 16:03 EST, Adam Williamson
no flags Details
File: backtrace (85.80 KB, text/plain)
2012-02-23 11:21 EST, Joshua Roys
no flags Details
Valgrind log (69.19 KB, text/plain)
2012-03-10 05:29 EST, drago01
no flags Details

  None (edit)
Description Adam Williamson 2011-11-16 16:03:20 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
comment:        Seems to happen a lot with regular usage of GNOME Shell in a current Rawhide VM: open Firefox, open abrt...it's pretty much unusable.
crash_function: _int_free
executable:     /usr/bin/gnome-shell
kernel:         3.2.0-0.rc1.git4.1.1.fc17.x86_64
pid:            1354
pwd:            /home/test
reason:         Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
time:           Wed 16 Nov 2011 12:05:24 PM PST
uid:            1000
username:       test

backtrace:      Text file, 83499 bytes
build_ids:      Text file, 7011 bytes
dso_list:       Text file, 21269 bytes
maps:           Text file, 82267 bytes
var_log_messages: Text file, 2749 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=ea8deae021ea42fcc710735400000002-1321473725.725997-1082224651
:GNOME_KEYRING_CONTROL=/tmp/keyring-OoMmQT
:IMSETTINGS_MODULE=none
:USER=test
:USERNAME=test
:MAIL=/var/spool/mail/test
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/test/.local/bin:/home/test/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/test
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1147
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/test
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=test
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-gijzovUeUH,guid=53c4d2a76d55958437296d420000000e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/test
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-test-2BlWrT/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1150,unix/unix:/tmp/.ICE-unix/1150
:GPG_AGENT_INFO=/tmp/keyring-OoMmQT/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-OoMmQT/ssh
:DESKTOP_AUTOSTART_ID=10e926f314be71ae2613214737268325300000011500000
Comment 1 Adam Williamson 2011-11-16 16:03:22 EST
Created attachment 534088 [details]
File: dso_list
Comment 2 Adam Williamson 2011-11-16 16:03:24 EST
Created attachment 534089 [details]
File: build_ids
Comment 3 Adam Williamson 2011-11-16 16:03:25 EST
Created attachment 534090 [details]
File: var_log_messages
Comment 4 Adam Williamson 2011-11-16 16:03:27 EST
Created attachment 534091 [details]
File: maps
Comment 5 Adam Williamson 2011-11-16 16:03:28 EST
Created attachment 534092 [details]
File: backtrace
Comment 6 Adam Williamson 2011-11-16 16:06:34 EST
in case this is more glibc hilarity - this is with glibc-2.14.90-16.x86_64 .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2011-11-16 16:18:02 EST
gnome team reckons this looks like an llvmpipe bug; ccing ajax for now, pending reassignment.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Joshua Roys 2012-02-23 11:21:45 EST
Running F17 RC4 under KVM (rhel6) using spice.  gnome-shell seems to crash when desktop effects try to get applied?  The first crash (this one) happened when I tried to open 'profile preferences' in gnome terminal.  The second happened when I opened system settings.  This might be specific to spice (?) because I had browsed around system settings with no issues over the regular VNC... but then switched to spice because of mouse lag.

backtrace_rating: 4
Package: gnome-shell-3.3.5-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Joshua Roys 2012-02-23 11:21:49 EST
Created attachment 565329 [details]
File: backtrace
Comment 10 Adam Williamson 2012-02-28 13:00:00 EST
Yeah, I think it is particular to Spice.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2012-02-28 13:03:17 EST
re-assigning and proposing as Beta blocker: this makes F17's default desktop borderline unusable in a default F16/F17 VM configuration, you can't really _do_ anything substantial without it crashing. If I want to do anything in an F17 VM I have to force fallback mode. Criterion "The release must install and boot successfully as a virtual guest in a situation where the virtual host is running the previous stable Fedora release, using Fedora's current preferred virtualization technology" combined with Alpha criterion "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments. The web browser must be able to download files, load extensions, and log into FAS", I guess - it's pretty hard to get all the way through testing the second before Shell crashes.
Comment 12 Adam Williamson 2012-03-02 13:17:21 EST
Discussed at 2011-03-02 blocker review meeting. Accepted as a blocker per criterions cited in comment #11, meeting agreed this case is severe enough to merit blockeriness.

The reproducer is just to run Shell in a Spice/QXL VM for a few minutes, really. Try and do anything and it falls over soon enough.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Kamil Páral 2012-03-02 13:19:58 EST
I can reproduce gnome-shell crash when navigating to System Settings -> Display. 100% "success". Happens just with spice/qxl.
Comment 14 Jason Brooks 2012-03-02 14:15:53 EST
I'm running the F17 alpha on oVirt (so, KVM & Spice). I experienced this same issue initially, but found that Gnome Shell runs w/o crashing with the vesa driver. Not ideal, but a workaround.
Comment 15 drago01 2012-03-10 05:29:44 EST
Created attachment 569074 [details]
Valgrind log
Comment 16 Aioanei Rares 2012-03-12 14:00:49 EDT
I am running an up-to-date F17 with kvm on a Debian host and can't even get to gdm. I get the "Something's wrong! Contact your system administrator" screen, with nothing else to do. If I start from runlevel three and issue startx (.xinitrc's contents are simply 'exec gnome-session'), it seems to work though. I installed with the F17 alpha livecd.
Comment 17 Aioanei Rares 2012-03-13 07:42:58 EDT
Today's update to spice-gtk3 seems to have solved the issue.
Comment 18 Adam Jackson 2012-03-14 13:44:16 EDT
Finally managed to track this down, and it turns out to really be a bug in the qxl driver (in particular in the uxa prepare/finish_access hooks).  Very much not where I was expecting that bug to be.

Reassigning to qxl driver.
Comment 19 Fedora Update System 2012-03-15 14:37:05 EDT
xorg-x11-drv-qxl-0.0.22-0.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-qxl-0.0.22-0.fc17
Comment 20 Fedora Update System 2012-03-15 22:44:51 EDT
Package xorg-x11-drv-qxl-0.0.22-0.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-qxl-0.0.22-0.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3887/xorg-x11-drv-qxl-0.0.22-0.fc17
then log in and leave karma (feedback).
Comment 21 Adam Williamson 2012-03-16 17:23:45 EDT
This looks pretty good. I have a VM that's made it all the way through a liveinst run. It used to crash way, way faster than that.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Adam Williamson 2012-03-16 17:56:07 EDT
There's a note in the update:

"This release has a different bug that causes rendering corruption in some cases, so I'm holding off on it for now."

We do need a fix for this bug in time for RC compose Tuesday, though. So can that be addressed? Thanks.
Comment 23 Adam Williamson 2012-03-16 22:00:07 EDT
Adam - is there any chance this bug was also causing #747464 ? I've noticed that I haven't triggered that bug, yet, with builds that have this xorg-x11-drv-qxl...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Adam Williamson 2012-03-19 19:53:44 EDT
Bump: Dave, Ajax, can you please comment on my question in comment #22? It's critical to Beta. Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 abrt-bot 2012-03-20 14:31:50 EDT
*** Bug 802013 has been marked as a duplicate of this bug. ***
Comment 26 Kamil Páral 2012-03-21 10:52:25 EDT
Setting as VERIFIED, and the update is pending to stable now.
Comment 27 Fedora Update System 2012-03-21 15:08:38 EDT
xorg-x11-drv-qxl-0.0.22-0.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.