Bug 75459 - False double-click activation on icons
Summary: False double-click activation on icons
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-08 19:15 UTC by Kumaran Santhanam
Modified: 2015-01-08 00:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 19:15:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kumaran Santhanam 2002-10-08 19:15:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a folder in Nautilus with a few folders in it
2. Make sure there is some empty space in that window
3. Pick a folder icon to open, but don't click on it yet
4. Quickly:  click on the empty space, then on that folder icon


Actual Results:  The selected folder opens.

Expected Results:  The folder should simply be selected, since the double-click
was not performed at the same pixel location.

To see the proper behavior, click on the empty space, wait for
2 seconds, then click on the folder icon.


Additional info:

I haven't looked at the code, but it seems that the canvas
widget must be registering double-click events even for
clicks that are not local to each other.  What isn't clear is
if this is a Gnome library problem, or specific to Nautilus.

Comment 1 Havoc Pennington 2002-10-08 20:52:06 UTC
I'm moving this bug to http://bugzilla.gnome.org/show_bug.cgi?id=95213

Closing on Red Hat level. We will get a fix with new upstream versions.


Note You need to log in before you can comment on or make changes to this bug.