Bug 754637 - 'J' and 'K' navigation keys trigger when entering text in the TM search box
'J' and 'K' navigation keys trigger when entering text in the TM search box
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks: Zanata-1.4.3
  Show dependency treegraph
 
Reported: 2011-11-17 02:10 EST by David Mason
Modified: 2012-04-23 00:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: Zanata version 1.4.3-alpha-3-SNAPSHOT (20111128-1320)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 00:33:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2011-11-17 02:10:36 EST
Description of problem:

When typing in the TM search field, typing j or k causes a navigation event which clears the text in the TM search field (because a new TM search is triggered)


Version-Release number of selected component (if applicable):
1.4.3-SNAPSHOT and 1.5-SNAPSHOT

How reproducible:
Always

Steps to Reproduce:
1.Sign in to translation editor
2.Click to focus on the TM search box
3.Type "girls just wanna have fun"
  
Actual results:
navigation event clears "girls j"
search box has "ust wanna have fun"

Expected results:
no navigation occurs
search box has "girls just wanna have fun"

Additional info:
Comment 1 Hedda Peters 2011-11-22 01:08:41 EST
Something similar for the full text search box of the worksspace - unable to type letters J and K in the search box, J and K keystrokes are simply being ignored, subsequent letters type fine.

On the other hand, typing J and K in the TM search box works fine for me.

Looking at Zanata version 1.4.2 (20111031-0915) here.
Comment 2 David Mason 2011-11-22 01:36:52 EST
J and K in the full text search box of the workspace is causing a navigation event in the loaded document (you just don't see it because the editor table is hidden):

1. open a document with 3 or more text units, select the first row
2. click project name to see doc list
3. click search box and type "kayak"
4. click project name to return to document

Actual results:
 - "aya" in search box
 - third TU is selected

Expected Results:
 - "kayak" in search box
 - first TU still selected
Comment 3 Alex Eng 2011-11-22 22:02:03 EST
Apparently IBUS input method intercept key capturing and provide a temporary workaround for this bug.
Comment 4 Alex Eng 2011-11-23 18:48:08 EST
Problem occurs due to the 'J' and 'K' capturing for navigation mode in translation table. Changed shortcut key to use ALT+J and ALT+K for navigation mode to eliminate any possible text field problem with single char capturing.

Fixed in 1.5

See https://github.com/zanata/zanata/commit/87a54bc4eac5490600830d0a8ec3e486a4b664e9
Comment 7 Ding-Yi Chen 2011-11-30 00:09:51 EST
VERIFIED with Zanata version 1.4.3-alpha-3-SNAPSHOT (20111128-1320)
and Zanata version 1.5-SNAPSHOT (20111129-0927)

Note You need to log in before you can comment on or make changes to this bug.