Bug 754689 - CGI::Session emits deprecation warning when running under 'use warnings'
Summary: CGI::Session emits deprecation warning when running under 'use warnings'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-CGI-Session
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-17 11:30 UTC by Simon Andrews
Modified: 2012-09-17 22:59 UTC (History)
5 users (show)

Fixed In Version: perl-CGI-Session-4.35-14.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-31 00:57:36 UTC
Type: ---


Attachments (Terms of Use)
Fix (1.30 KB, patch)
2012-08-21 15:10 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
CPAN 69048 0 None None None 2012-08-21 15:03:16 UTC

Description Simon Andrews 2011-11-17 11:30:47 UTC
Description of problem:

The F16 version of CGI session issues a deprecation warning when run under the version of perl shipped with F16


Version-Release number of selected component (if applicable):
perl-CGI-Session-4.35-9.fc16.noarch
perl-5.14.2-190.fc16.i686

How reproducible:

Always


Steps to Reproduce:
1. perl -MCGI::Session -Mwarnings -e 'exit'
  
Actual results:

Use of qw(...) as parentheses is deprecated at /usr/share/perl5/vendor_perl/CGI/Session.pm line 882.

Expected results:

No warning.

Additional info:

Comment 1 Simon Andrews 2011-11-17 11:37:27 UTC
The fix is to change line 882 from:

foreach my $plug qw(driver serializer id) {

to

foreach my $plug (qw(driver serializer id)) {

Comment 2 hkoba 2012-06-14 09:04:46 UTC
This problem still persists in F17.

  % perl -MCGI::Session -we0
  Use of qw(...) as parentheses is deprecated at
  /usr/share/perl5/vendor_perl/CGI/Session.pm line 882.

This problem is already fixed in upstream CGI-Session-4.48

  % cd ~/.local/share/.cpan/build/CGI-Session-4.48-IEMe8O
  % perl -Mblib -MCGI::Session -we0
  %

So, please update it!

Comment 3 David Tonhofer 2012-08-08 11:24:46 UTC
Bump; crosslink to bug#782599

This bug is relevant to Fedora 17

Comment 4 Simon Andrews 2012-08-21 08:53:30 UTC
I've sent a mail to the perl-sig group to see if anyone there is able to apply the patch to fix this since there has been no response from the package maintainer.

Comment 5 Petr Pisar 2012-08-21 15:03:16 UTC
All Fedoras are affected.

Comment 6 Petr Pisar 2012-08-21 15:10:00 UTC
Created attachment 605963 [details]
Fix

Comment 7 Fedora Update System 2012-08-21 15:33:08 UTC
perl-CGI-Session-4.35-14.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-CGI-Session-4.35-14.fc18

Comment 8 Fedora Update System 2012-08-21 15:34:14 UTC
perl-CGI-Session-4.35-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-CGI-Session-4.35-12.fc17

Comment 9 Fedora Update System 2012-08-21 15:36:56 UTC
perl-CGI-Session-4.35-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-CGI-Session-4.35-10.fc16

Comment 10 Fedora Update System 2012-08-21 17:06:36 UTC
Package perl-CGI-Session-4.35-14.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-CGI-Session-4.35-14.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12391/perl-CGI-Session-4.35-14.fc18
then log in and leave karma (feedback).

Comment 11 hkoba 2012-08-24 06:30:06 UTC
Thank you for your response!

I have just installed perl-CGI-Session-4.35-12.fc17 above
and it worked just fine.

BTW, I can't login to koji (because of ssl cert error
, in both of chrome20 and FF13)
so I can't send any feedback.

Does anyone know any workaround for koji web login ssl issue?
(Or, is this occur only for me?)

Comment 12 Simon Andrews 2012-08-24 06:38:53 UTC
Koji uses a self-signed certificate, which appears to have changed recently.  In firefox there is an option to trust the new certificate which should make things work.

The system for providing karma is the bodhi link above though which should work without problem though.

Comment 13 Fedora Update System 2012-08-31 00:57:36 UTC
perl-CGI-Session-4.35-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-08-31 00:58:33 UTC
perl-CGI-Session-4.35-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2012-09-17 22:59:45 UTC
perl-CGI-Session-4.35-14.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.