This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 754694 - /lib64/libz.so.1: no version information available
/lib64/libz.so.1: no version information available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: zlib (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Schiffer
Tomas Dolezal
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-17 06:57 EST by Johnny Hughes
Modified: 2013-02-21 05:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Zlib library was not providing version information. Consequence: Some applications using zlib library might not work properly with missing version information. Fix: Supply zlib.map version script, which provides version information. Result: Zlib library is now providing version information.
Story Points: ---
Clone Of: 557651
Environment:
Last Closed: 2013-02-21 05:10:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Johnny Hughes 2011-11-17 06:57:01 EST
+++ This bug was initially created as a clone of Bug #557651 +++

======================================

Description of problem:
Got the above error message when I run Google Chrome or any other application that requires version information in libz.so.1.

I am submitting in regard to libz.so.1 without version information available, but not the difficulties of using chrome. Users should have same error if they run an application that requires version information on libz.so.1

Version-Release number of selected component (if applicable):
zlib-1.2.3-26.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install RHEL 6.
2. Install all packages needed.
3. Install Google Chrome from a 3rd party repo.
3. Start Google Chrome.
  
It starts with the error message:

/lib64/libz.so.1: no version information available

Additional info:
N/A

+++++++++++++++++++original bug comments++++++++++++++++++++++++++++++++

--- Additional comment from jh.redhat@plonk.de on 2010-02-12 04:58:04 EST ---

google-chrome-beta-5.0.307.7-38400.x86_64 at least doesn't crash any more, but the error message ist still there.

This is probably the same problem as in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=431124, the fix sounds to be quite small.

--- Additional comment from caius.chance@gmail.com on 2010-02-14 19:41:03 EST ---

If you could kindly patch it on Fedora that would be fantastic. if you decide to let be then that's alright. Thanks very much for your help.

--- Additional comment from varekova@redhat.com on 2010-03-31 09:45:38 EDT ---

Thanks, fixed in zlib-1.2.4-1.fc14.

--- Additional comment from felipe.contreras@gmail.com on 2010-06-16 13:49:26 EDT ---

What would be needed to get this on F13?

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comment 4 Suzanne Yeghiayan 2012-02-14 18:20:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 16 errata-xmlrpc 2013-02-21 05:10:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0398.html

Note You need to log in before you can comment on or make changes to this bug.