Bug 75476 - maximize/full-screen together lose screen-size info
maximize/full-screen together lose screen-size info
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 18:14 EDT by Yaron Minsky
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 18:14:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaron Minsky 2002-10-08 18:14:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
By doing maximize and fullscreen in the right sequence, metacity loses track of
the size of the original window.  You end up with a window the size of the
fullscreen but unmaximized, so it's hard to shrink it down because you can't
reach the edges to drag it to normal size.

This may seem like a silly bug (why would you do that anyway?) but it turns out
that if you use fullscreen a lot, then this happens sometimes by mistake.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Bind maximize and fullscreen toggles to, say, keys <Control>m and <Control>f
respectively.  Then type:

<Control>f<Control>m<Control>f<Control>m



Additional info:
Comment 1 Havoc Pennington 2002-10-08 18:25:02 EDT
This is fixed in upstream metacity CVS, we'll get the fix on next metacity 
version upgrade.

Note You need to log in before you can comment on or make changes to this bug.