Bug 75483 - Suspend broken on Dell Latitude C400
Suspend broken on Dell Latitude C400
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 19:02 EDT by Jason Tibbitts
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 12:26:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2002-10-08 19:02:57 EDT
I have a Dell Latitude C400 which will not awaken from suspend mode.  The screen
is restored but the keyboard and mouse are frozen.  Sometimes (if I suspend from
a text VT) there is a message indicating that the BIOS does not restore PCI
state properly, and that resume=force should be used if the resume freezes. 
This unfortunately does not help.  There are also occasionally complaints from
the USB (UHCI) driver:

usb-uhci.c: interrupt, status 20, frame# 470
usb-uhci.c: Host controller halted, trying to restart.

In an attempt to ensure that the problem is the kernel and not the much-hacked X
server I require to get graphics on this platform, I booted with init=/bin/sh. 
The problem reoccurs.  I can suspend and restore from within Grub without problems.

I have an identical machine running an older kernel that suspends fine. so I
installed every Red Hat kernel I could find and tested them.  I found that the
latest version I can get which works is 2.4.18-10.98 (I had pulled this from
rawhide some time ago); 2.4.18-11 from (null) fails.  The only difference
between the package changelogs is:

* Tue Aug 13 2002 Arjan van de Ven <arjanv@redhat.com>
 
- added audigy driver bits

but I have yet to pull apart the SRPMs to see what exactly changed.
Comment 1 Arjan van de Ven 2002-10-09 04:33:01 EDT
I'm pretty sure the i586 kernel will work. There's an interaction with a bug in
dell bioses and OPROFILE; oprofile is only present in the i686 kernel, so the
i586 one should "fix" this. Can you test this ?
Comment 2 Jason Tibbitts 2002-10-09 11:28:47 EDT
I installed and booted the i586 kernel; it runs fine.  Is there a kernel
parameter  to shut this off, or can I just turn off %patch1480 in the RPM and
rebuild?
Comment 3 Fortepianissimo 2002-10-09 12:26:45 EDT
Just to confirm that this happened to Dell Inspiron 4100 and 8200 as well.
Comment 4 Arjan van de Ven 2002-10-18 07:01:37 EDT
fixed in erratum..

Note You need to log in before you can comment on or make changes to this bug.