Bug 754857 - anaconda doesn't check if there is enough free disk space
anaconda doesn't check if there is enough free disk space
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2011-11-17 17:24 EST by Christoph Wickert
Modified: 2012-04-03 14:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 14:32:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-11-17 17:24:45 EST
Description of problem:
anaconda doesn't check if there is enough free disk space at the beginning of the install bug fails with an error later.

Version-Release number of selected component (if applicable):
anaconca-16.25-1.fc16

How reproducible:
always

Steps to Reproduce:
1. Try to install Fedora-16-x86_64-Live-Desktop.iso on a 6 GB HD (e.g. in KVM or Virtual box). The machine has 1 GB RAM, so the default / will be 4 GB

Actual results:
Install fails when progressbar is at ~95%:
"There was an error installing the live image to your hard drive. This could be due to bad media. Please verify your installation media.

If you exit, your system will be left in an inconsistent state that will require reinstallation."

Expected results:
Should either install or warn at the beginning of the install.

Additional info:
When anaconda stops only 58% of / are used and 1.7 GB are still free. With 8 GB HD or 6 GB / everything is fine.
Comment 1 Matthias Runge 2012-04-03 02:54:12 EDT
Still valid for upgrade from f16 to f17. In this case this is more evil, because usr-move is executed, then the installer drops out, leaving system in inconsistent state.

Version from f17 beta-rc2, I had about 2.2 GB free space on /, no own /usr partition.
Comment 2 Brian Lane 2012-04-03 14:32:35 EDT
This is no longer a problem in F17. I've tested it with 4, 6 and 8G drives and it complains on 4 and 6 and installs on 8.

Matthias, could you open a new bug about the upgrade with as much detail as possible? source media, how you wrote it to the media, size of partitions and logs from /tmp/*log attached as individual plain/text files.

Note You need to log in before you can comment on or make changes to this bug.