Bug 754909 - libvirt: Failed to find path for dmidecode binary
libvirt: Failed to find path for dmidecode binary
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Eric Blake
Fedora Extras Quality Assurance
:
: 696702 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 02:40 EST by Pavel Zhukov
Modified: 2012-09-27 02:43 EDT (History)
13 users (show)

See Also:
Fixed In Version: libvirt-0.9.6-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-05 15:59:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Zhukov 2011-11-18 02:40:07 EST
minimal installation of F16. 

There are multiply errors in logs:
09:51:34.859: 18344: error : virSysinfoRead:465 : internal error Failed to find path for dmidecode binary

libvirt doen't require dmidecode.
Comment 1 Steven Dake 2011-11-28 21:06:07 EST
I am finding this dmidecode error occurs at a similar time as when Bug #757382 occurs.  In Fedora 16, dmidecode isn't installed by default.  It could be that this results in the failure to finish forking (assumed failure) in Bug #75382.
Comment 2 Michael Scherer 2011-11-29 09:19:32 EST
*** Bug 696702 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Admin XMLRPC Client 2011-11-30 14:33:21 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 14:36:58 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 14:44:23 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 14:54:57 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Eric Blake 2011-12-05 12:39:49 EST
Patch proposed:
https://www.redhat.com/archives/libvir-list/2011-December/msg00227.html
Comment 8 Steven Dake 2011-12-05 13:12:51 EST
Eric,

Note I have been running with Daniel's original patch for about a week and no lockups occur.
Comment 9 Eric Blake 2011-12-05 14:16:25 EST
(In reply to comment #8)
> Eric,
> 
> Note I have been running with Daniel's original patch for about a week and no
> lockups occur.

We should backport this patch to F16:
commit e7dfa468f9de796430a4cc9594eb256109a517bf
Author: Eric Blake <eblake@redhat.com>
Date:   Mon Dec 5 10:32:41 2011 -0700

    spec: add dmidecode as prereq
    
    https://bugzilla.redhat.com/show_bug.cgi?id=754909 complains that
    because libvirt didn't require dmidecode, that the logs are noisy
    and virConnectGetSysinfo needlessly fails.  Even 'virt-what' requires
    dmidecode, so it's not that onerous of a dependency.  We may be
    able to drop this in the future when we move to parsing sysfs data,
    but for now, listing the dependency will help matters.
    
    * libvirt.spec.in (Requires): Sort Requires before BuildRequires.
    Add dmidecode.
Comment 10 Eric Blake 2011-12-05 14:17:30 EST
(In reply to comment #8)
> Eric,
> 
> Note I have been running with Daniel's original patch for about a week and no
> lockups occur.

I also meant to add that Daniel's patches for lockup are independently addressed in bug 757382.
Comment 11 Fedora Update System 2011-12-19 21:09:07 EST
libvirt-0.9.6-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libvirt-0.9.6-4.fc16
Comment 12 Fedora Update System 2011-12-22 17:35:12 EST
Package libvirt-0.9.6-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.9.6-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17267/libvirt-0.9.6-4.fc16
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-01-05 15:59:57 EST
libvirt-0.9.6-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.