Bug 754997 - Gnome-shell restarts randomly and sometimes craches
Gnome-shell restarts randomly and sometimes craches
Status: CLOSED DUPLICATE of bug 725165
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-11-18 09:12 EST by Hicham BOUSHABA
Modified: 2011-11-29 15:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-11-29 14:35:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 661323 None None None Never

  None (edit)
Description Hicham BOUSHABA 2011-11-18 09:12:47 EST
Description of problem: gnome-shell restarts itself randomly, and sometimes it craches and closes the session.

Version-Release number of selected component (if applicable):
gnome-shell 3.2

Additional info:
this is the error message:
ERROR:gi/object.c:671:gjs_object_instance_constructor: assertion failed: (unthreadsafe_template_for_constructor.info == NULL || strcmp(g_base_info_get_name( (GIBaseInfo*) priv->info), g_base_info_get_name( (GIBaseInfo*) unthreadsafe_template_for_constructor.info)) == 0)
** Message: applet now removed from the notification area
gnome-shell-calendar-server[11236]: Got HUP on stdin - exiting
gnome-session[1464]: WARNING: Application 'gnome-shell.desktop' killed by signal
gnome-session[1464]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Comment 1 Hicham BOUSHABA 2011-11-19 05:06:52 EST
Any response!!!
Comment 2 Michael Cronenworth 2011-11-23 12:14:55 EST
Upstream knows about it, but no fix has been made yet. I see this on only one of three machines I use daily. They all have very similar hardware (same video driver for instance) and all the same shell extensions.
Comment 3 Michael Cronenworth 2011-11-29 13:26:08 EST
@Hicham, do you have the Gnome Shell Weather extension installed and enabled?
Comment 4 Michael Cronenworth 2011-11-29 14:35:13 EST

*** This bug has been marked as a duplicate of bug 725165 ***
Comment 5 Hicham BOUSHABA 2011-11-29 15:21:16 EST
effectively, the origin of problem was from Weather extension, I disabled it, and now I'm fine :). thanks

Note You need to log in before you can comment on or make changes to this bug.