Bug 75500 - Anaconda Crushes on Harddisk installs if psyche-docs.iso exists
Anaconda Crushes on Harddisk installs if psyche-docs.iso exists
Status: CLOSED DUPLICATE of bug 75077
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 03:33 EDT by Andrew Koros
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 03:35:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A dump trace from Anaconda (43.79 KB, text/plain)
2002-10-09 03:35 EDT, Andrew Koros
no flags Details

  None (edit)
Description Andrew Koros 2002-10-09 03:33:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Bad: When doing harddisk installation upgrade having placed the iso iamages in
one directory, if psyche-doc.iso is in that directory the installer will crush

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Place psyche-docs.iso, psyche-i386-disc1.iso, psyche-i386-disc2.iso,
psyche-i386-disc3.iso in one directory

2. Create a boot floppy using boot.img  boot to start the installation upgrade
and select the  harddisk installation option
3. At the point where the installer starts to checked for the installed packages
it should crush.
	

Actual Results:  Anaconda crushes with a messages suggesting a bug report and
installtion can no longer continue.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/text.py", line 446,
in run
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
150, in gotoNext
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
215, in moveStep
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/packages.py", line
115, in readPackages
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/harddrive.py", line
209, in readHeaders
TypeError: an integer is required


Expected Results:  The installer should have moved on to give package upgrade
selections or moved on to actually install the upgraded packages

Additional info:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/text.py", line 446,
in run
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
150, in gotoNext
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
215, in moveStep
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/packages.py", line
115, in readPackages
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/harddrive.py", line
209, in readHeaders
TypeError: an integer is required

Local variables in innermost frame:
sys: <module 'sys' (built-in)>
h: rhl-gsg-en
self: <harddrive.HardDriveInstallMethod instance at 0x852370c>
hl: <comps.HeaderListFromFile instance at 0x823bb44>


Dispatcher instance, containing members:
method: HardDriveInstallMethod instance, containing members:
  messageWindow: <bound method InstallInterface.messageWindow of
<text.InstallInterface instance at 0x82e67b4>>
  discImages: {1: psyche-docs.iso, 2: psyche-i386-disc2.iso, 3:
psyche-i386-disc3.iso}
  fnames: {}
  isoDir: /mnt/sysimage/home/
  tree: None
  rootPath: /mnt/sysimage
  fstype: ext2
  device: hda9
  path: koros/downloads/RHL8.0
  mediaIsMounted: 0
  isoDirIsMounted: 0
step: 34
intf: InstallInterface instance, containing members:
  instLanguage: InstallTimeLanguage instance, containing members:
    current: en_US
    map: {'Swedish': iso15, 'Danish': iso15, 'Icelandic': iso15,
'Chinese(Simplified)': None, 'Norwegian': iso15,
'German': iso09, 'Dutch': iso15, 'Slovenian': iso02, 'Japanese': None, 'French':
iso15, 'Czech': iso02, 'Portuguese': iso15, 'Ukrainian': koi8-u, 'Spanish':
iso15, 'English': iso01, 'Russian': koi8-r, 'Korean': None,
'Chinese(Traditional)': None, 'Italian': iso15}
    tempDefault:
    nativeLangNames: {}
    langList: [Chinese(Simplified), Chinese(Traditional), Czech, Danish, Dutch,
English, French, German, Icelandic, Italian, Japanese, Korean, Norwegian,
Portuguese, Russian, Slovenian, Spanish, Swedish, Ukrainian]
    langNicks: {'Swedish': sv_SE, 'Danish': da_DK, 'Icelandic': is_IS,
'Chinese(Simplified)': zh_CN.GB18030, 'Norwegian': no_NO, 'German': de_DE,
'Dutch': nl_NL, 'Slovenian': sl_SI, 'Japanese': ja_JP.eucJP, 'French': fr_FR,
'Czech': cs_CZ, 'Portuguese': pt_PT@euro, 'Ukrainian': uk_UA, 'Spanish': es_ES,
'English': en_US, 'Russian': ru_RU.koi8r, 'Korean': ko_KR.eucKR,
'Chinese(Traditional)': zh_TW.Big5, 'Italian': it_IT}
    font: {'Swedish': lat0-sun16, 'Danish': lat0-sun16, 'Icelandic': lat0-sun16,
'Chinese(Simplified)': None, 'Norwegian': lat0-sun16, 'German': lat0-16,
'Dutch': lat0-sun16, 'Slovenian': lat2-sun16, 'Japanese': Kon, 'French':
lat0-sun16, 'Czech': lat2-sun16, 'Portuguese': lat0-sun16, 'Ukrainian':
cyr-sun16, 'Spanish': lat0-sun16, 'English': default8x16, 'Russian': cyr-sun16,
'Korean': None, 'Chinese(Traditional)': None, 'Italian': lat0-sun16}
    kbd: {'Swedish': se-latin1, 'Danish': us, 'Icelandic': is-latin1,
'Chinese(Simplified)': us, 'Norwegian': no-latin1, 'German':
de-latin1-nodeadkeys, 'Dutch': nl, 'Slovenian': slovene, 'Japanese': jp106,
'French': fr-latin1,
'Czech': cz-lat2, 'Portuguese': pt-latin1, 'Ukrainian': ua, 'Spanish': es,
'English': us, 'Russian': ru, 'Korean': us, 'Chinese(Traditional)': us,
'Italian': it}
    tz: {'Swedish': Europe/Stockholm, 'Danish': Europe/Copenhagen, 'Icelandic':
Atlantic/Reykjavik, 'Chinese(Simplified)': Asia/Shanghai, 'Norwegian':
Europe/Oslo, 'German': Europe/Berlin, 'Dutch': Europe/Amsterdam, 'Slovenian':
Europe/Ljubljana, 'Japanese': Asia/Tokyo, 'French': Europe/Paris, 'Czech':
Europe/Prague, 'Portuguese': Europe/Lisbon, 'Ukrainian': Europe/Kiev, 'Spanish':
Europe/Madrid, 'English': America/New_York, 'Russian': Europe/Moscow, 'Korean':
Asia/Seoul, 'Chinese(Traditional)': Asia/Taipei, 'Italian': Europe/Rome}
  langSearchPath: [en_US, en, C]
  showingHelpOnHelp: 0
  welcomeText: Red Hat Linux (C) 2002 Red Hat, Inc.
  screen: SnackScreen instance, containing members:
    width: 80
    helpCb: <bound method InstallInterface.helpWindow of <text.InstallInterface
instance at 0x82e67b4>>
height: 25
  configFileData: {'TitleBar': pixmaps/anaconda_header.png, 'Title': Red Hat
Linux Beta, 'Splashscreen': pixmaps/first.png, 'WelcomeScreen': pixmaps/splash.png}
flags: Flags instance, containing members:
  flags: {'test': 0, 'setupFilesystems': 1, 'serial': 0, 'expert': 0, 'autostep': 0}
dispatch: Already dumped
instPath: /mnt/sysimage
firstStep: 0
id: InstallData instance, containing members:
  compspkg: None
  dbpath: None
  firewall: Firewall instance, containing members:
    ftp: 0
    http: 0
    portlist:
    enabled: -1
    telnet: 0
    custom: 1
    ssh: 0
    policy: 1
    dhcp: 0
    smtp: 0
    trustdevs: []
    ports: []
  upgradeSwapInfo: None
  firstboot: 0
  hdList: None
  auth: Authentication instance, containing members:
    hesiodLhs:
    useKrb5: 0
    nisuseBroadcast: 1
    useShadow: 1
    sambaServer:
    krb5Realm:
    nisDomain:
    sambaWorkgroup:
    ldapTLS:
    useMD5: 1
    useSamba: 0
    ldapBasedn:
    krb5Admin:
    enableCache: 0
    useLdapauth: 0
    hesiodRhs:
    ldapServer:
    useHesiod: 0
    krb5Kdc:
    useLdap: 0
    nisServer:
    useNIS: 0
  upgradeRoot: [('hda5', 'ext3')]
  comps: None
  dependencies: []
  accounts: None
  fsset: FileSystemSet instance, containing members:
    messageWindow: <bound method InstallInterface.messageWindow of
<text.InstallInterface instance at 0x82e67b4>>
    waitWindow: <bound method InstallInterface.waitWindow of
<text.InstallInterface instance at 0x82e67b4>>
    mountcount: 8
    entries: [fsentry -- device: hda5   mountpoint: /
           fsystem: ext3 format: 0

, fsentry -- device: hda1   mountpoint: /boot
           fsystem: ext3 format: 0

, fsentry -- device: none   mountpoint: /dev/pts
           fsystem: devpts format: 0

, fsentry -- device: none   mountpoint: /dev/shm
 fsystem: tmpfs format: 0

, fsentry -- device: hda9   mountpoint: /home
           fsystem: ext3 format: 0

, fsentry -- device: none   mountpoint: /proc
           fsystem: proc format: 0

, fsentry -- device: hda6   mountpoint: /usr
           fsystem: ext3 format: 0

, fsentry -- device: hda7   mountpoint: /var
           fsystem: ext3 format: 0

, fsentry -- device: hda8   mountpoint: swap
           fsystem: swap format: 0

]
    progressWindow: <bound method InstallInterface.progressWindow of
<text.InstallInterface instance at 0x82e67b4>>
    migratedfs: 0
Comment 1 Andrew Koros 2002-10-09 03:35:28 EDT
Created attachment 79564 [details]
A dump trace from Anaconda
Comment 2 Jeremy Katz 2002-10-09 11:38:21 EDT
As you've already discovered, the easy workaround is just to move the
documentation CD to a different directory.

*** This bug has been marked as a duplicate of 75077 ***

Note You need to log in before you can comment on or make changes to this bug.