Bug 755003 - No serial console getty when used with console=ttyS0 console=tty0
Summary: No serial console getty when used with console=ttyS0 console=tty0
Keywords:
Status: CLOSED DUPLICATE of bug 691374
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-18 14:40 UTC by Jan ONDREJ
Modified: 2012-01-02 14:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-02 14:00:03 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2011-11-18 14:40:13 UTC
Description of problem:
When starting system with this order of consoles:
  console=ttyS0 console=tty0
I plan to use both VGA and serial consoles on my system. Problems running other combination of console settings is described in bug#652215 (which started with Fedora 14).
But if console=ttyS0 is not default console (last kernel parameter), systemd doesn't start getty service on this console. Please update autodetection or make at least some workaround to overwrite this setting.

Version-Release number of selected component (if applicable):
systemd-37-3.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot kernel with: nomodeset console=ttyS0 console=tty0
  
Actual results:
no getty on serial console

Expected results:
login: prompt on serial console

Comment 1 Michal Schmidt 2011-11-18 16:38:06 UTC
A workaround is:
ln -s /lib/systemd/systemd/serial-getty@.service /etc/systemd/system/getty.target.wants/serial-getty@ttyS0.service

Comment 2 Jan ONDREJ 2011-11-18 19:13:10 UTC
(In reply to comment #1)
> A workaround is:
> ln -s /lib/systemd/systemd/serial-getty@.service
> /etc/systemd/system/getty.target.wants/serial-getty@ttyS0.service

Doesn't work. Even if "login:" prompt is displayed, I can't type my login/password. When typing "root" it presses enters and ends with "Login incorrect". :-(

Fedora release 16 (Verne)
Kernel 3.1.1-1.fc16.x86_64 on an x86_64 (ttyS0)

fedora-16 login: root
Heslo: 
Login incorrect

login: 
Heslo: 
Login incorrect

First time login is accepted, but password is entered after first char is pressed. Looks like agetty process works well, but when login is started, it is sharing /dev/ttyS0 with another process. lsof doesn't say anything interesant for me.

Comment 3 Michal Schmidt 2011-11-18 22:04:01 UTC
That's likely not a systemd bug, but plymouth doing funky stuff with the terminal settings. See https://bugzilla.redhat.com/show_bug.cgi?id=691374#c4 for a workaround.

Comment 4 Michal Schmidt 2012-01-02 14:00:03 UTC
(In reply to comment #0)
> But if console=ttyS0 is not default console (last kernel parameter), systemd
> doesn't start getty service on this console. Please update autodetection or
> make at least some workaround to overwrite this setting.

So this is expected behaviour. Only the last console= gets a serial getty spawned automatically by systemd.

That leaves us with the issue of broken serial console settings, which is a plymouth bug.

*** This bug has been marked as a duplicate of bug 691374 ***


Note You need to log in before you can comment on or make changes to this bug.