This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 755019 - actions in bundle deployment log Table should be sorted chronologically
actions in bundle deployment log Table should be sorted chronologically
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.2
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: jon30-bugs jon30-sprint10/rhq43-sprint10
  Show dependency treegraph
 
Reported: 2011-11-18 10:11 EST by Ian Springer
Modified: 2013-08-05 20:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:20:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (157.45 KB, image/png)
2011-11-18 10:12 EST, Ian Springer
no flags Details

  None (edit)
Description Ian Springer 2011-11-18 10:11:11 EST
They are currently not sorted at all. See attached screenshot.
Comment 1 Ian Springer 2011-11-18 10:12:09 EST
Created attachment 534410 [details]
screenshot
Comment 2 John Mazzitelli 2011-12-06 16:25:52 EST
master commit: 8a2f8f8

there is one minor issue - there appears to be a smartgwt bug where the sort direction is set to ascending, but the icon that shows up is the down arrow (meaning, it looks like its sorted in descending order). In my testing, however, it really is sorted in ascending order (which is what we want).

When we upgrade to smartgwt 2.5, hopefully, that minor nuisance is fixed.

But aside from the reversed icon that shows in the column's header cell, this bug is fixed - the audit trail is now sorted on the timestamp field.
Comment 3 Sunil Kondkar 2011-12-13 05:49:00 EST
Verified in latest master build#829 (Version: 4.3.0-SNAPSHOT Build Number: 35fcafb)

The audit trail is sorted by default on the timestamp field in ascending order. Verified sorting is working on all columns in audit trail.
Comment 4 Mike Foley 2012-02-07 14:20:25 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.