Bug 7551 - Xconfigurator doesn't know Cyrix MediaGX can't do 1280x1024
Xconfigurator doesn't know Cyrix MediaGX can't do 1280x1024
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-03 11:24 EST by Telsa Gwynne
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 17:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 1999-12-03 11:24:36 EST
Running 6.1 on a machine with a Cyrix MediaGX chip and 64megs RAM.
Had an old monitor that X worked with. Got a new one:a Sony CPD-110EST.

Ran Xconfigurator and it told me it had found settings for it, but the
ones it suggested were 1280x1024x8bit. Although the monitor might cope,
I'm told the MediaGX has a limit of 1024x768.

Called in friendly neighbourhood hacker (every home should have one) to
sort it out. I'm now using an XF86Config with
this in it:

# 1024x768 @ 76 Hz, 62.5 kHz hsync
# Modeline "1024x768"    85    1024 1032 1152 1360   768  784  787  823
Modeline "1024x768"    85    1024 1040 1152 1360   768  784  787  823

This is working fine.

So far :)
Comment 1 Trond Eivind Glomsrxd 2000-07-11 14:15:26 EDT
Does this work in Red Hat Linux 6.2?
Comment 2 Trond Eivind Glomsrxd 2000-07-26 10:20:15 EDT
Xconfigurator doesn't have a way to specify minimum/maximum resolution (also a
problem with LCD displays) - intend to fix this with a planned rewrite.
Comment 3 Trond Eivind Glomsrxd 2000-07-26 10:20:43 EDT
Oh - and of course, the workaround is to select the resoultion you know your
computer can handle.
Comment 4 Telsa Gwynne 2000-08-02 08:21:54 EDT
It does not work any better in 6.2.

The workaround only works if you are prepared to edit the
XF86Config file by hand. If I select combinations of resolutions
and depths in Xconfigurator, it claims to accept them and then
writes a non-working XF86Config.
Comment 5 Brock Organ 2001-02-09 17:44:11 EST
Here is an update on the issue from Telsa, the reporter:

Date: Fri, 9 Feb 2001 08:44:37
+0000                                               
From: Telsa Gwynne
<hobbit@aloss.ukuu.org.uk>                                      
Subject: Cyrix MediaGX text-mode upgrade: step right
up!                           

...
                                                                                   
It's not all doom and gloom: Xconfigurator --preferxf3 gets
the                    
Cyrix right. Woo-hoo! Thank you! (Please someone with privs,
update                
#7551 so that everyone knows this is now working: unless you
can                   
see the other beta-team-only bug, you don't know that
Xconfigurator                
was fixed for 7.0, and I keep meeting people with Cyrixes and
no                   
working X because they don't know there's a new
Xconfigurator.)                    
                                                                                   
Telsa                                                                              

Note You need to log in before you can comment on or make changes to this bug.