Bug 755104 - Review Request: condor-wallaby - condor related tools for interacting with wallaby
Summary: Review Request: condor-wallaby - condor related tools for interacting with wa...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nuno Santos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-18 20:56 UTC by Robert Rati
Modified: 2013-09-12 22:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-10 20:33:27 UTC
nsantos: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Robert Rati 2011-11-18 20:56:41 UTC
Spec URL: http://rrati.fedorapeople.org/condor-wallaby.spec
SRPM URL: http://rrati.fedorapeople.org/condor-wallaby-4.1.2-1.fc15.src.rpm
Description: condor specific tools for interacting with wallaby

Comment 1 Nuno Santos 2011-12-22 15:58:19 UTC
I've reviewed the package, comments below in the guidelines template:

============================
See notes - MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.
$ rpmlint /var/lib/mock/fedora-rawhide-i386/result/condor-wallaby*.rpm
condor-wallaby.src:36: W: unversioned-explicit-obsoletes condor-remote-configuration
condor-wallaby.src:54: W: unversioned-explicit-obsoletes condor-remote-configuration-server
condor-wallaby.src: W: no-%build-section
condor-wallaby.src: W: invalid-url Source0: condor-wallaby-4.1.2.tar.gz
condor-wallaby-client.noarch: W: obsolete-not-provided condor-remote-configuration
condor-wallaby-client.noarch: W: conffile-without-noreplace-flag /etc/condor/config.d/99configd.config
condor-wallaby-client.noarch: W: no-manual-page-for-binary condor_configd
2 packages and 0 specfiles checked; 0 errors, 7 warnings.

NOTES: no build section, invalid url for source, obsolete not provided, and config file without noreplace flag warnings should be fixed

OK - MUST: The package must be named according to the Package Naming Guidelines .

OK - MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption.

OK - MUST: The package must meet the Packaging Guidelines .

OK (ASL 2.0) - MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .

OK - MUST: The License field in the package spec file must match the actual license.

OK - MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.

OK - MUST: The spec file must be written in American English.

OK - MUST: The spec file for the package MUST be legible.

See notes - MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.

NOTES: unable to check md5sums, is it possible to get the tarfile upstream?

OK - MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture.

$ mock -r fedora-rawhide-i386 condor-wallaby-4.1.2-1.fc15.src.rpm 
INFO: mock.py version 1.1.18 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
INFO: Start(condor-wallaby-4.1.2-1.fc15.src.rpm)  Config(fedora-rawhide-i386)
State Changed: lock buildroot
State Changed: clean
INFO: chroot (/var/lib/mock/fedora-rawhide-i386) unlocked and deleted
State Changed: unlock buildroot
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.18
INFO: Mock Version: 1.1.18
INFO: calling preinit hooks
INFO: enabled root cache
State Changed: unpacking root cache
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
State Changed: unlock buildroot
INFO: Installed packages:
State Changed: setup
State Changed: build
INFO: Done(condor-wallaby-4.1.2-1.fc15.src.rpm) Config(fedora-rawhide-i386) 2 minutes 17 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-i386/result
State Changed: end


NA - MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line.

OK - MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.

NA - MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.

NA - MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun.

OK - MUST: Packages must NOT bundle copies of system libraries.

NA - MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker.

OK - MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory.

OK - MUST: A Fedora package must not list a file more than once in the spec file's %files listings. (Notable exception: license texts in specific situations)

OK - MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example.

OK - MUST: Each package must consistently use macros.

OK - MUST: The package must contain code, or permissable content.

NA - MUST: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity).

OK - MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present.

NA - MUST: Header files must be in a -devel package.

NA - MUST: Static libraries must be in a -static package.

NA - MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package.

NA - MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name}%{?_isa} = %{version}-%{release}

OK - MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.

NA - MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation.

OK - MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time.

OK - MUST: All filenames in rpm packages must be valid UTF-8.


NA - SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.

NA - SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available.

OK - SHOULD: The reviewer should test that the package builds in mock.

NOTES: see mock output above

OK - SHOULD: The package should compile and build into binary rpms on all supported architectures.

OK - SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.

NOTES: has had extensive testing as part of MRG

NA - SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity.

NA - SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency.

NA - SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb.

NA - SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself.

NO - SHOULD: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.
============================


To summarize:

- There are a few warnings that should be fixed (namely the no build section, invalid url for source, obsolete not provided, and config file without noreplace flag warnings)

- Is it possible to get the tarfile hosted upstream (to enable md5sum checking)?

- The source tarfile uses .gz suffix but is not gzipped:
$ tar -xvzf condor-wallaby-4.1.2.tar.gz 

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

$ head condor-wallaby-4.1.2.tar.gz 
condor-wallaby-4.1.2/0000775000076400007640000000000011661543014013472 5ustar  rratirraticondor-wallaby-4.1.2/condor_configure_store0000775000076400007640000007007011661543014020165 0ustar  rratirrati#!/usr/bin/python
#   Copyright 2008 Red Hat, Inc.
#
#   Licensed under the Apache License, Version 2.0 (the "License");
#   you may not use this file except in compliance with the License.
#   You may obtain a copy of the License at
#
#       http://www.apache.org/licenses/LICENSE-2.0
#
#   Unless required by applicable law or agreed to in writing, software

Comment 2 Robert Rati 2012-01-06 16:27:21 UTC
Fixed the issues, with a few exceptions.  The obsolete not provided is for a package that never existed in fedora.  I've handled it with a conditional for the binaries, but the srpm will still show the warning.  I've also changed the config without noreplace file to a regular non-config file.  The file is in /etc, but contains condor config snipets that shouldn't be edited by the user.  If the user wants to modify things, they should create their own config file and have it parsed last.

Spec URL: http://rrati.fedorapeople.org/condor-wallaby.spec
SRPM URL: http://rrati.fedorapeople.org/condor-wallaby-4.1.2-2.fc15.src.rpm

Comment 3 Nuno Santos 2012-01-10 16:49:35 UTC
I've checked the fixes and have re-reviewed the affected parts:


OK - MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.

md5sums match:

$ rpm2cpio condor-wallaby-4.1.2-2.fc15.src.rpm | cpio -ivd ; md5sum condor-wallaby-4.1.2.tar.gz
0001-Packaging-improvements-for-building-on-fedora.patch
0002-Packaging-fixes.patch
0003-Workflow-and-packaging-improvements.patch
0004-Bumped-spec-to-4.1.2-2.patch
condor-wallaby-4.1.2.tar.gz
condor-wallaby.spec
261 blocks
2bc4dfcf7e6e3368c8a33d43af29406f  condor-wallaby-4.1.2.tar.gz

$ wget https://fedorahosted.org/releases/g/r/grid/condor-wallaby-4.1.2.tar.gz ; md5sum condor-wallaby-4.1.2.tar.gz
--2012-01-10 11:38:51--  https://fedorahosted.org/releases/g/r/grid/condor-wallaby-4.1.2.tar.gz
Resolving fedorahosted.org... 66.135.62.191
Connecting to fedorahosted.org|66.135.62.191|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 51416 (50K) [application/x-gzip]
Saving to: “condor-wallaby-4.1.2.tar.gz”

100%[==========================================================>] 51,416       199K/s   in 0.3s    

2012-01-10 11:38:52 (199 KB/s) - “condor-wallaby-4.1.2.tar.gz” saved [51416/51416]

2bc4dfcf7e6e3368c8a33d43af29406f  condor-wallaby-4.1.2.tar.gz


OK - MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture.

$ mock -r fedora-rawhide-i386 condor-wallaby-4.1.2-2.fc15.src.rpm 
INFO: mock.py version 1.1.18 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
INFO: Start(condor-wallaby-4.1.2-2.fc15.src.rpm)  Config(fedora-rawhide-i386)
State Changed: lock buildroot
State Changed: clean
INFO: chroot (/var/lib/mock/fedora-rawhide-i386) unlocked and deleted
State Changed: unlock buildroot
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.18
INFO: Mock Version: 1.1.18
INFO: calling preinit hooks
INFO: enabled root cache
INFO: root cache aged out! cache will be rebuilt
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
State Changed: creating cache
State Changed: unlock buildroot
INFO: Installed packages:
State Changed: setup
State Changed: build
INFO: Done(condor-wallaby-4.1.2-2.fc15.src.rpm) Config(fedora-rawhide-i386) 4 minutes 16 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-i386/result
State Changed: end


OK - MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

$ rpmlint /var/lib/mock/fedora-rawhide-i386/result/condor-wallaby*.rpm
condor-wallaby.src:41: W: unversioned-explicit-obsoletes condor-remote-configuration
condor-wallaby.src:61: W: unversioned-explicit-obsoletes condor-remote-configuration-server
condor-wallaby-client.noarch: W: non-conffile-in-etc /etc/condor/config.d/99configd.config
condor-wallaby-client.noarch: W: no-manual-page-for-binary condor_configd
2 packages and 0 specfiles checked; 0 errors, 4 warnings.

(Warnings have been explained in earlier comments)


* tarfile issue has been fixed as well:

$ tar -xvzf condor-wallaby-4.1.2.tar.gz 
condor-wallaby-4.1.2/
condor-wallaby-4.1.2/LICENSE-2.0.txt
condor-wallaby-4.1.2/Makefile
condor-wallaby-4.1.2/README
condor-wallaby-4.1.2/condor-wallaby.spec
condor-wallaby-4.1.2/condor_configd
condor-wallaby-4.1.2/condor_configure_pool
condor-wallaby-4.1.2/condor_configure_store
condor-wallaby-4.1.2/config/
condor-wallaby-4.1.2/config/99configd.config
condor-wallaby-4.1.2/config/pidkill.bat
condor-wallaby-4.1.2/doc/
condor-wallaby-4.1.2/doc/condor_configure_pool.1
condor-wallaby-4.1.2/doc/condor_configure_store.1
condor-wallaby-4.1.2/module/
condor-wallaby-4.1.2/module/WallabyHelpers.py
condor-wallaby-4.1.2/module/WallabyTypes.py
condor-wallaby-4.1.2/module/__init__.py
condor-wallaby-4.1.2/module/exceptions.py
condor-wallaby-4.1.2/test/
condor-wallaby-4.1.2/test/override.param
condor-wallaby-4.1.2/test/override/
condor-wallaby-4.1.2/test/override/.gitignore
condor-wallaby-4.1.2/test/store.rb
condor-wallaby-4.1.2/test/test_driver.py
condor-wallaby-4.1.2/test/test_procedures.txt


==========

It all looks good now, package is APPROVED.

Comment 4 Robert Rati 2012-01-10 16:56:42 UTC
New Package SCM Request
=======================
Package Name: condor-wallaby
Short Description: condor specific tools for interacting with wallaby
Owners: rrati
Branches: f15 f16
InitialCC: matt

Comment 5 Gwyn Ciesla 2012-01-10 17:13:19 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2012-01-10 20:35:15 UTC
condor-wallaby-4.1.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/condor-wallaby-4.1.2-2.fc15

Comment 7 Fedora Update System 2012-01-10 20:36:23 UTC
condor-wallaby-4.1.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/condor-wallaby-4.1.2-2.fc16

Comment 8 Fedora Update System 2012-01-11 21:44:06 UTC
condor-wallaby-4.1.2-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/condor-wallaby-4.1.2-3.fc15

Comment 9 Fedora Update System 2012-01-11 21:44:56 UTC
condor-wallaby-4.1.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/condor-wallaby-4.1.2-3.fc16

Comment 10 Fedora Update System 2012-01-25 22:30:51 UTC
condor-wallaby-4.1.2-3.fc16 has been pushed to the Fedora 16 stable repository.

Comment 11 Fedora Update System 2012-01-25 22:35:14 UTC
condor-wallaby-4.1.2-3.fc15 has been pushed to the Fedora 15 stable repository.


Note You need to log in before you can comment on or make changes to this bug.