Bug 75530 - enlightenment-0.16.4-7 needs libImlib.so.1
Summary: enlightenment-0.16.4-7 needs libImlib.so.1
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: enlightenment (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-09 16:05 UTC by Christopher Sylvain
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 20:12:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Sylvain 2002-10-09 16:05:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
after upgrade from RH7.3 to 8.0, imlib-1.9.13-9 provides libImlib.so.11,
but enlightenment-0.16.4-7 still requires libImlib.so.1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ldd /usr/bin/enlightenment
2.
3.
	

Actual Results:  can't login after selecting enlightenment with desktop
switching tool,
because enlightenment crashes

Additional info:

workaround: create symlink for libImlib.so.1 pointing to libImlib.so.11
 ??

Comment 1 Brent Fox 2002-10-10 20:12:02 UTC
We haven't shipped enlightenment since 7.2.  I'm not sure there's anything we
can really do about this.

Comment 2 Havoc Pennington 2002-10-10 20:20:36 UTC
It probably would have been nice to do a compat lib for the old imlib, 
but we didn't, and it's too late really.

If you want to use enlightenment you'll need to recompile it.

Comment 3 Christopher Sylvain 2002-10-14 21:33:33 UTC
Ok, fine.  Why didn't the 7.3->8.0 upgrade tell me it was deprecated?
or 8.0 does not provide the libImlib.so.1 required?
or WARN due to unsatisfied dependency?
(how am I to know unless I examine the dependencies of each of the 600-plus
packages on my system before and after the upgrade?  I really think this is
best handled by a communicative automaton)
  ???



Note You need to log in before you can comment on or make changes to this bug.