Bug 755328 - can't access http://my.verizon.com with mozilla-https-everywhere enabled
Summary: can't access http://my.verizon.com with mozilla-https-everywhere enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla-https-everywhere
Version: rawhide
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Russell Golden
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-20 18:04 UTC by Andre Robatino
Modified: 2012-04-27 06:12 UTC (History)
1 user (show)

Fixed In Version: mozilla-https-everywhere-2.0.2-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-24 04:23:12 UTC


Attachments (Terms of Use)

Description Andre Robatino 2011-11-20 18:04:16 UTC
Description of problem:
With mozilla-https-everywhere enabled, can't access http://my.verizon.com . There appears to be some kind of infinite loop. A workaround is to use the url https://my.verizon.com . I'm guessing this is a bug in the website but want to confirm.

Version-Release number of selected component (if applicable):
mozilla-https-everywhere-1.1-1.fc16.noarch

How reproducible:
always

Comment 1 Russell Golden 2011-12-07 23:16:54 UTC
Is this still present in HTTPS Everywhere 1.2.1?

Comment 2 Russell Golden 2011-12-07 23:19:14 UTC
Seems it is... I'm gonna forward this upstream. Thanks.

Comment 3 Andre Robatino 2011-12-07 23:24:39 UTC
(In reply to comment #1)
> Is this still present in HTTPS Everywhere 1.2.1?

Yep, still easily reproducible with mozilla-https-everywhere-1.2.1-1.fc16.noarch (as you discovered) by clicking on http://my.verizon.com . Using https://my.verizon.com still works, but the links in the emails Verizon sends don't work due to this issue.

Comment 4 Russell Golden 2011-12-25 20:48:35 UTC
They're planning to release a new version in mid-jan that fixes this. I'll see if I can backport the fix from Git. Sorry this is taking so long.

Comment 5 Russell Golden 2012-01-11 17:36:12 UTC
Pushing an update to updates-testing now that should fix this. Please test it and give it a shot.

Comment 6 Fedora Update System 2012-01-11 17:38:47 UTC
mozilla-https-everywhere-1.2.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mozilla-https-everywhere-1.2.2-1.fc16

Comment 7 Andre Robatino 2012-01-11 17:59:14 UTC
Does not work. As before, http://my.verizon.com/ has the infinite loop, and https://my.verizon.com/ does not.

Comment 8 Fedora Update System 2012-01-15 19:55:12 UTC
Package mozilla-https-everywhere-1.2.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mozilla-https-everywhere-1.2.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0454/mozilla-https-everywhere-1.2.2-1.fc16
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-01-24 07:54:41 UTC
mozilla-https-everywhere-1.2.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Andre Robatino 2012-01-24 08:04:51 UTC
As indicated in comment 7, this update does not fix the bug.

Comment 11 Russell Golden 2012-01-24 20:37:56 UTC
Well crap. Reproduced here. Forwarding upstream again. Sorry.

Comment 12 Andre Robatino 2012-02-29 20:52:23 UTC
Still broken with Koji's mozilla-https-everywhere-2.0.1-1.fc16.

Comment 13 Russell Golden 2012-03-02 15:25:29 UTC
Yeah. It'll be fixed in 2.0.2, likely. The fix was committed after 2.0.1's release.

I might even backport the fix, if I can remember how to generate a diff file.

Sorry this is taking so long.

Comment 14 Andre Robatino 2012-03-02 19:38:20 UTC
No big rush, I'm willing to wait for the upstream version. But out of curiosity, I take it that this is actually a bug in the extension itself, and not in Verizon's website? I ask because Verizon's monthly emails send me to a different, longer URL, and I'm hoping that the fix is general so it covers that as well.

Comment 15 Russell Golden 2012-03-03 15:21:02 UTC
I'm pretty sure it's a bug in Verizon's site.

Comment 16 Andre Robatino 2012-04-13 02:09:18 UTC
Also seen in x86_64 Rawhide with mozilla-https-everywhere-2.0.1-1.fc17.noarch.

Comment 17 Fedora Update System 2012-04-20 18:38:06 UTC
mozilla-https-everywhere-2.0.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mozilla-https-everywhere-2.0.2-1.el6

Comment 18 Fedora Update System 2012-04-20 18:38:14 UTC
mozilla-https-everywhere-2.0.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mozilla-https-everywhere-2.0.2-1.fc16

Comment 19 Fedora Update System 2012-04-20 18:38:41 UTC
mozilla-https-everywhere-2.0.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mozilla-https-everywhere-2.0.2-1.fc17

Comment 20 Fedora Update System 2012-04-20 18:38:51 UTC
mozilla-https-everywhere-2.0.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mozilla-https-everywhere-2.0.2-1.fc15

Comment 21 Fedora Update System 2012-04-20 18:38:56 UTC
mozilla-https-everywhere-2.0.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mozilla-https-everywhere-2.0.2-1.el5

Comment 22 Andre Robatino 2012-04-22 23:20:52 UTC
This appears fixed in Rawhide with mozilla-https-everywhere-2.0.2-1.fc18.noarch. Will also verify in F16 and F17 and provide Bodhi karma.

Comment 23 Fedora Update System 2012-04-24 04:23:12 UTC
mozilla-https-everywhere-2.0.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2012-04-24 14:55:47 UTC
mozilla-https-everywhere-2.0.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2012-04-24 15:01:45 UTC
mozilla-https-everywhere-2.0.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2012-04-27 06:11:51 UTC
mozilla-https-everywhere-2.0.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2012-04-27 06:12:00 UTC
mozilla-https-everywhere-2.0.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.