Bug 755331 - Kaffeine segmentation fault (proprietary nvidia driver)
Kaffeine segmentation fault (proprietary nvidia driver)
Status: CLOSED DUPLICATE of bug 751891
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
16
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 13:36 EST by Juhani Jaakola
Modified: 2011-11-21 07:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-20 15:55:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juhani Jaakola 2011-11-20 13:36:54 EST
Description of problem:
When I start Kaffeine, it crashes with a segmentation fault (11).

Version-Release number of selected component (if applicable):
kaffeine-1.2.2-1.fc16.i686
phonon-backend-xine-4.4.4-3.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1. Start Kaffeine
  
Actual results:
Crashes with a segmentation fault (11)

Expected results:
Starts Kaffeine and allows to play m2t files (recorded DVB-T programmes).

Additional info:
Kaffeine works fine in Fedora 15. When I upgraded to Fedora 16, I get this crash. I have heard that phonon-backend-xine is deprecated in Fedora 16 - perhaps that's why I have a fc15 version (phonon-backend-xine-4.4.4-3.fc15.i686)? The issue with phonon-backend-xine vs phonon-backend-gstreamer caused a segmentation fault in knotify4 as well, which I solved by installing phonon-backend-gstreamer and then erasing phonon-backend-xine. However, I still have this problem with Kaffeine.

KCrash shows the following stack backtrace:

#7  0x4fe48db4 in _dl_relocate_object () from /lib/ld-linux.so.2
#8  0x4fe503ab in dl_open_worker () from /lib/ld-linux.so.2
#9  0x4fe4bd0f in _dl_catch_error () from /lib/ld-linux.so.2
#10 0x4fe4fd06 in _dl_open () from /lib/ld-linux.so.2
#11 0x4105cc09 in dlopen_doit () from /lib/libdl.so.2
#12 0x4fe4bd0f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0x4105d3ba in _dlerror_run () from /lib/libdl.so.2
#14 0x4105ccb7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#15 0x41d408fc in ?? () from /usr/lib/libxine.so.1
#16 0x41d40dc0 in _x_scan_plugins () from /usr/lib/libxine.so.1
#17 0x41d35814 in xine_init () from /usr/lib/libxine.so.1
#18 0x0804ddee in _start ()

I have updated my system to the latest packages now.

Kaffeine is the BEST DVB-T (digital television) program available for Linux. It is ABSOLUTELY CRUCIAL to fix this issue so that we can watch DVB-T television via Linux!
Comment 1 Kevin Kofler 2011-11-20 13:53:07 EST
Kaffeine doesn't use phonon-backend-xine, but xine-lib directly. (phonon-backend-xine is actually no longer in Fedora and phonon-backend-gstreamer should be used instead, see also bug #752513, but Kaffeine doesn't use Phonon at all.)

Are you using the proprietary nvidia driver? If yes, see bug #751891. (The elf_machine_rela_relative and elf_dynamic_do_Rela functions are inlined and thus do not show up in a backtrace without debugging information like yours.)
Comment 2 Juhani Jaakola 2011-11-20 14:48:15 EST
Yes, I'm using the proprietary nVidia driver:

$ rpm -qa | grep nvidia
kmod-nvidia-3.1.1-1.fc16.i686-290.06-1.fc16.2.i686
kmod-nvidia-290.06-1.fc16.3.i686
nvidia-xconfig-1.0-10.fc16.i686
xorg-x11-drv-nvidia-290.06-2.fc16.i686
xorg-x11-drv-nvidia-libs-290.06-2.fc16.i686
kmod-nvidia-3.1.1-2.fc16.i686-290.06-1.fc16.3.i686
nvidia-settings-1.0-12.fc16.i686
Comment 3 Kevin Kofler 2011-11-20 15:55:52 EST
Switch to Nouveau and all your problems will go away.

*** This bug has been marked as a duplicate of bug 751891 ***
Comment 4 Juhani Jaakola 2011-11-21 03:50:28 EST
No, it did not help. I'm using nouveau now:

$ lsmod | grep nou
nouveau               532662  2 
ttm                    45950  1 nouveau
drm_kms_helper         23190  1 nouveau
drm                   157196  4 nouveau,ttm,drm_kms_helper
i2c_algo_bit            4166  1 nouveau
mxm_wmi                 1379  1 nouveau
i2c_core               21588  6 nouveau,drm_kms_helper,drm,i2c_algo_bit,videodev,i2c_i801
video                  10740  1 nouveau
$ uname -a
Linux localhost.localdomain 3.1.1-2.fc16.i686 #1 SMP Mon Nov 14 16:16:34 UTC 2011 i686 i686 i386 GNU/Linux

I still get a crash in Kaffeine, with this stack backtrace:

Application: Kaffeine (kaffeine-xbu), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#7  0x4fe48db4 in _dl_relocate_object () from /lib/ld-linux.so.2
#8  0x4fe503ab in dl_open_worker () from /lib/ld-linux.so.2
#9  0x4fe4bd0f in _dl_catch_error () from /lib/ld-linux.so.2
#10 0x4fe4fd06 in _dl_open () from /lib/ld-linux.so.2
#11 0x4105cc09 in dlopen_doit () from /lib/libdl.so.2
#12 0x4fe4bd0f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0x4105d3ba in _dlerror_run () from /lib/libdl.so.2
#14 0x4105ccb7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#15 0x41d408fc in ?? () from /usr/lib/libxine.so.1
#16 0x41d40dc0 in _x_scan_plugins () from /usr/lib/libxine.so.1
#17 0x41d35814 in xine_init () from /usr/lib/libxine.so.1
#18 0x0804ddee in _start ()

This is how I changed to nouveau, did I forget something?

- yum erase kmod-nvidia-3.1.1-2.fc16.i686-290.06-1.fc16.3.i686
- change nvidia to nouveau in /etc/X11/xorg.conf
- mv /etc/X11/xorg.conf.d/00-nvidia.conf /etc/X11/xorg.conf.d/00-nvidia.conf.nvidia
- mv /etc/modprobe.d/blacklist-nouveau.conf /etc/modprobe.d/blacklist-nouveau.conf.nvidia
- reboot
Comment 5 Kevin Kofler 2011-11-21 04:18:38 EST
You seem to have the nvidia libGL still installed, make sure you uninstall all nvidia-related packages (try "yum erase \*nvidia\*").
Comment 6 Juhani Jaakola 2011-11-21 07:16:28 EST
I tried "yum erase \*nvidia\*" and rebooted, now Kaffeine works! Thanks!

Note You need to log in before you can comment on or make changes to this bug.