Bug 755349 - f16 bash gets removed from /etc/shells by some package or event
f16 bash gets removed from /etc/shells by some package or event
Status: CLOSED DUPLICATE of bug 752827
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 15:46 EST by Reartes Guillermo
Modified: 2011-11-21 00:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 00:09:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2011-11-20 15:46:46 EST
Description of problem:

I instaled F16 KDE, udpated ok.
Created the first user, ok, its shell was bash.

Then i added, flash64, vbox and rpmfusion repos.
updated ok.

but when installing vbox extentions, it complained something strange
about the shell, and to mi surprise /etc/shells only contained
dash and nologin and the user i was using (the second user, created
later) its shell was dash !


Version-Release number of selected component (if applicable):


How reproducible:
unknown, i only installed f16 on my laptop once.

Steps to Reproduce:
1. install f16, update
2. add rpmfusion, install mplayer and some pluggins
3. add flash 64bit
4. add virtualbox, it installs but extensions cannot because
they cannot find  bash in /etc/shells. So i added it back.
  
Actual results:
after some time, i ended without bash in /etc/shells

Expected results:
/bin/bash should allways be in /etc/shells
is that correct?

Additional info:

setup.noarch         2.8.36-2.fc16          @koji-override-0/$releasever

Thanks in advance.
Comment 1 Andre Robatino 2011-11-20 20:19:33 EST
Probably a duplicate of bug 752827. Try "yum reinstall bash" to fix it.
Comment 2 Ondrej Vasik 2011-11-21 00:09:58 EST
Yes, it is a duplicate, closing...

*** This bug has been marked as a duplicate of bug 752827 ***

Note You need to log in before you can comment on or make changes to this bug.