Bug 755356 - clang fails to link
clang fails to link
Status: CLOSED DUPLICATE of bug 750187
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 16:42 EST by Steven Michael Williams
Modified: 2011-11-28 03:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 03:12:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Michael Williams 2011-11-20 16:42:34 EST
Description of problem:

clang fails to link any C code. I haven't checked C++ yet because of other issues that that has which have been reported, but this could be affecting that as well.

Version-Release number of selected component (if applicable):

2.9-4.f16

How reproducible:

Every compile.

Steps to Reproduce:
1. clang <source file>
  
Actual results:

/usr/bin/ld: cannot find crtbegin.o: No such file or directory
/usr/bin/ld: cannot find -lgcc
/usr/bin/ld: cannot find -lgcc_s
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Expected results:

A binary executable from C source code.
Comment 1 David Tardon 2011-11-28 03:12:43 EST

*** This bug has been marked as a duplicate of bug 750187 ***

Note You need to log in before you can comment on or make changes to this bug.