Bug 755369 - CRITICAL: Error parsing schema org.gnome.shell
Summary: CRITICAL: Error parsing schema org.gnome.shell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool
Version: 16
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-20 23:10 UTC by barsnick
Modified: 2012-01-22 22:56 UTC (History)
3 users (show)

Fixed In Version: gnome-tweak-tool-3.2.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-22 22:56:12 UTC


Attachments (Terms of Use)
the fix (883 bytes, application/x-php)
2012-01-05 15:49 UTC, Stas Sergeev
no flags Details

Description barsnick 2011-11-20 23:10:41 UTC
Description of problem:
I get this in the shell when calling gnome-tweak-tool:

CRITICAL: Error parsing schema org.gnome.shell
(/usr/share/glib-2.0/schemas/org.gnome.shell.gschema.xml)
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/gtweak/gsettings.py", line 45 in __init__ 
summary = key.getElementsByTagName("summary")[0].childNodes[0].data
IndexError: list index out of range

(gnome-tweak-tool:15057): Gtk-CRITICAL **:
gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:15057): Gtk-CRITICAL **:
gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

[Those last lines show up identically 15 times.]

Version-Release number of selected component (if applicable):
3.2.1-1.fc16 (updates-testing)
3.2.0-1.fc16

How reproducible:
always

Steps to Reproduce:
1. call gnome-tweak-tool from terminal
  
Actual results:
See messages above. (Everything else seems to work.)

Expected results:
No error messages.

Additional info:
Reported upstream as https://bugzilla.gnome.org/show_bug.cgi?id=664361
Duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=663695
gnome-tweak-tool 3.2.2 was released to resolve this. See bug #755182

Comment 1 NM 2011-12-01 22:54:49 UTC
Same here. 

uname -a
Linux armat1.home 3.1.2-1.fc16.x86_64 #1 SMP Tue Nov 22 09:00:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

gnome-shell --version
GNOME Shell 3.2.1

Comment 2 Stas Sergeev 2012-01-05 15:49:26 UTC
Created attachment 550951 [details]
the fix

The problem is that the org.gnome.shell.gschema.xml
contains elements with an empty summary:
---
    <key type="i" name="saved-im-presence">
      <default>1</default>
      <summary/>
---

while gsettings.py contains this:
---
#summary is compulsory, description is optional
---
which is not the case.

The fix is attached.

Comment 3 NM 2012-01-06 02:18:17 UTC
Thanks alot

Comment 4 Fedora Update System 2012-01-21 12:58:07 UTC
gnome-tweak-tool-3.2.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-tweak-tool-3.2.2-1.fc16

Comment 5 Fedora Update System 2012-01-22 05:26:32 UTC
Package gnome-tweak-tool-3.2.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-tweak-tool-3.2.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0780/gnome-tweak-tool-3.2.2-1.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-01-22 22:56:12 UTC
gnome-tweak-tool-3.2.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.