Bug 755444 - blogtk fail on start
Summary: blogtk fail on start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blogtk
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paul W. Frields
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-21 06:58 UTC by Vincent passaro
Modified: 2011-11-30 01:54 UTC (History)
2 users (show)

Fixed In Version: blogtk-2.0-6.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-30 01:54:23 UTC
Type: ---


Attachments (Terms of Use)

Description Vincent passaro 2011-11-21 06:58:32 UTC
Description of problem: blogtk fails to start properly


Version-Release number of selected component (if applicable):
Name        : blogtk
Version     : 2.0
Release     : 5.fc16
Architecture: noarch
Install Date: Sun 20 Nov 2011 10:48:07 PM PST
Group       : Applications/Internet
Size        : 588960
License     : BSD
Signature   : RSA/SHA256, Mon 01 Aug 2011 01:46:24 PM PDT, Key ID 067f00b6a82ba4b7
Source RPM  : blogtk-2.0-5.fc16.src.rpm
Build Date  : Mon 01 Aug 2011 09:08:36 AM PDT
Build Host  : x86-15.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://blogtk.sourceforge.net
Summary     : GNOME application for editing/maintaining blogs
Description :
BloGTK is a weblog posting client written in Python for any platform that
supports Python and the GTK widget set. BloGTK allows you to connect to your
weblog with XML-RPC and create new posts.

How reproducible: Always


Steps to Reproduce:
1. yum install blogtk.noarch
2. run blogtk
3. Fail occurs
  
Actual results: blogtk does not start properly


Expected results: blogtk should start


Additional info:

[root@W520 ~]# blogtk2 
ImportError: could not import bonobo.ui

(blogtk2:12933): libglade-WARNING **: unknown widget class 'GnomeAppBar'

(blogtk2:12933): libglade-WARNING **: unknown widget class 'GnomeAppBar'
Traceback (most recent call last):
  File "/usr/bin/blogtk2", line 7, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/blogtk2/main.py", line 768, in main
    blogtk.main()
  File "/usr/lib/python2.7/site-packages/blogtk2/main.py", line 243, in main
    self.initPostList()
  File "/usr/lib/python2.7/site-packages/blogtk2/main.py", line 225, in initPostList
    self.checkListing(None)
  File "/usr/lib/python2.7/site-packages/blogtk2/main.py", line 418, in checkListing
    self.appbar.push(_('Click refresh on toolbar to retrieve list of recent posts'))
AttributeError: 'gtk.Label' object has no attribute 'push'

Comment 1 Paul W. Frields 2011-11-21 13:33:22 UTC
This is caused by a missing gnome-python2-bonobo package dependency.  Creating a package update that will fix this problem.

Comment 2 Fedora Update System 2011-11-21 13:37:54 UTC
blogtk-2.0-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/blogtk-2.0-6.fc16

Comment 3 Vincent passaro 2011-11-21 19:20:44 UTC
Great!  Once I get the update I will go adjust karma.

How long eta to make it into the updates repo?

Comment 4 Fedora Update System 2011-11-21 22:54:48 UTC
Package blogtk-2.0-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blogtk-2.0-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16219/blogtk-2.0-6.fc16
then log in and leave karma (feedback).

Comment 5 Vincent passaro 2011-11-23 08:03:07 UTC
Resolved!

Thank you! 

Will leave karma Feedback.

Comment 6 Vincent passaro 2011-11-23 08:14:30 UTC
Should I close this?

Comment 7 Paul W. Frields 2011-11-23 12:49:55 UTC
No, please leave the bug open.  It will be closed automatically by the update system when the update either reaches +3 karma (automatic push), or once I push it after it remains there at least a week with no negative karma.  Until then it's considered in ON_QA state.

Comment 8 Fedora Update System 2011-11-30 01:54:23 UTC
blogtk-2.0-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.