Bug 755506 - [RFE] Add host-based access control to sssd
[RFE] Add host-based access control to sssd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.2
All Linux
medium Severity low
: rc
: 6.3
Assigned To: Stephen Gallagher
IDM QE LIST
: FutureFeature, Triaged
: 766924 785878 (view as bug list)
Depends On:
Blocks: 607248
  Show dependency treegraph
 
Reported: 2011-11-21 05:51 EST by J.H.M. Dassen (Ray)
Modified: 2013-07-03 00:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.8.0-2.el6.beta2
Doc Type: Enhancement
Doc Text:
Cause: SSSD had no facility for comparing the contents of the 'authorizedHost' attribute of a user to the hostname on the client system. Consequence: Users of SSSD could not take advantage of the functionality in pam_ldap provided by the pam_check_host_attr option. Change: SSSD added a new feature and option to the LDAP access_provider, allowing users to enable the behavior of pam_check_host_attr. Result: SSSD users can now set the 'ldap_access_order = host' and 'ldap_user_authorized_host' options to enable access-control based on the presence of this attribute in LDAP.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 36912 None None None Never
FedoraHosted SSSD 746 None None None Never

  None (edit)
Description J.H.M. Dassen (Ray) 2011-11-21 05:51:01 EST
3. What is the nature and description of the request?

Need to have sssd check the user's host attribute, similar to how nss_ldap
"pam_check_host_attr yes" config worked.

        4. Why does the customer need this? (List the business requirements
        here)

Currently there is no way to configure host-based access control without
involving IPA.  Customer would have to revert back to pam_ldap or maintain
their own sssd package.

        5. How would the customer like to achieve this? (List the functional
        requirements here)

Backport the patch from https://fedorahosted.org/sssd/ticket/746
https://fedorahosted.org/sssd/changeset/3612c73e7957721bcbf31d0118e2ac210eb46b88

        6. For each functional requirement listed in question 4, specify how
        Red Hat and the customer can test to confirm the requirement is
        successfully implemented.

Configure sssd.conf with access_provider=ldap and ldap_access_order=host.
Verify that sssd checks the host attribute in the user's ldap entry to
determine access privilege. 

        7. Is there already an existing RFE upstream or in Red Hat bugzilla?

Fixed upstream through <https://fedorahosted.org/sssd/ticket/746>.

        8. Does the customer have any specific timeline dependencies?

RHEL 6.3

        9. Is the sales team involved in this request and do they have any
        additional input?

No

        10. List any affected packages

sssd

        11. Would the customer be able to assist in testing this
        functionality if implemented?

Yes
Comment 4 Dmitri Pal 2012-01-05 12:26:37 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/746
Comment 5 Jenny Galipeau 2012-01-12 10:05:32 EST
*** Bug 766924 has been marked as a duplicate of this bug. ***
Comment 6 Jenny Galipeau 2012-01-30 15:44:12 EST
*** Bug 785878 has been marked as a duplicate of this bug. ***
Comment 10 Jenny Galipeau 2012-03-27 08:34:08 EDT
QE test coverage complete, marking verified
Comment 11 Stephen Gallagher 2012-06-12 09:08:45 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: SSSD had no facility for comparing the contents of the 'authorizedHost' attribute of a user to the hostname on the client system.

Consequence: Users of SSSD could not take advantage of the functionality in pam_ldap provided by the pam_check_host_attr option.

Change: SSSD added a new feature and option to the LDAP access_provider, allowing users to enable the behavior of pam_check_host_attr.

Result: SSSD users can now set the 'ldap_access_order = host' and 'ldap_user_authorized_host' options to enable access-control based on the presence of this attribute in LDAP.
Comment 13 errata-xmlrpc 2012-06-20 07:49:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.