Bug 75551 - mkswap only formatted 128K
mkswap only formatted 128K
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 16:46 EDT by Gene Czarcinski
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 10:10:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-10-09 16:46:34 EDT
Description of Problem:
I recently purchased a new MaxStor model 6Y080L0 80GB ide drive and installed it
as /dev/hdc.  One interesting part is that the drive did NOT come up in LBA32
mode.  Instead, fdisk -l reports a geometry of 16 heads, 63 sectors, 158816
cylinders.  This seems to work OK and I was even able to install and run a
system in /dev/hdc1 which allocated:
   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1   *         1      8127   4095976+  83  Linux
/dev/hdc2          8128     10159   1024128   82  Linux swap

As you can see, hdc2 is a swap area.  I tried to format it with mkswap using the
command:
   mkswap -c /dev/hdc2
but it reported that it formatted only 131072 (128K).  I tried this several
times but it repeated.  I then tried specifying a size:
   mkswap -c /dev/hdc2 512
This did nothing.

I then used parted to format the swap area and it did the full 1GB.  After that,
I tried mkswap again and it now reported the full 1048576.

Version-Release number of selected component (if applicable):
8.0

How Reproducible:
yes, but not after I formatted with parted
Comment 1 Gene Czarcinski 2002-10-10 10:09:56 EDT
I had to rebuild the disk.  This time mkswap worked OK.

I am not sure how repeatable this will be and would understand this being closed
"WORKS4ME"
Comment 2 Elliot Lee 2002-10-13 12:02:03 EDT
Done. :)

Note You need to log in before you can comment on or make changes to this bug.