Bug 75564 - Default font not applied to all virtual consoles
Default font not applied to all virtual consoles
Status: CLOSED DUPLICATE of bug 89446
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-09 17:52 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2002-10-09 17:52:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 

Description of problem:
After changing the locale to a non utf8 one (because unicode seems broken to 
me in many ways, already reported here in bugzilla) I also changed the console 
font to lat9-16 (SYSFONT="lat9-16" in /etc/sysconfig/i18n). But now this font 
is only applied to the first virtual console and not the other ones. In 7.3 
this worked fine.

How reproducible:

Steps to Reproduce:
1.in /etc/sysconfig/i18n change the default locate to, say, pt_PT.iso885915
2.change the default font to lat9-16
3.reboot just to make sure

Actual Results:  After the system is back up, only the first virtual console 
uses the correct font, you cah check this by trying to use an accented 
character at the login prompt

Expected Results:  The font should be applied to all vt's like it used to 
happen in 7.3.
Comment 1 Eido Inoue 2003-02-19 16:09:05 EST
font settings not being inherited by all the vts is a known kernel bug (or is it
a feature?)
Comment 2 Carlos Rodrigues 2003-09-06 22:22:54 EDT

*** This bug has been marked as a duplicate of 89446 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.