Bug 755673 - Adding new drift: includes/excludes - Path property required?
Adding new drift: includes/excludes - Path property required?
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.2
All All
medium Severity low (vote)
: ---
: ---,RHQ 4.3.0
Assigned To: Jay Shaughnessy
Mike Foley
: FutureFeature
Depends On:
Blocks: 707225 jon30-sprint10/rhq43-sprint10
  Show dependency treegraph
 
Reported: 2011-11-21 13:08 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:26:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2011-11-21 13:08:26 EST
This one is just a little usability enhancement

Description of problem: When defining includes/excludes in new drift there is no need to require path property not to be empty. For case, when I have base directory set to lets say /opt/drifts and I want to only specify a few include masks I am forced to put '.' into Path field. 


Version-Release number of selected component (if applicable):
JON 3.0.0.CR2

How reproducible: always


Steps to Reproduce:
1. Create new drift from File-System Template
2. Define some base dir
3. Specify you want to include only *.txt files within base dir
  
Actual results: you are forced to insert '.' symbol to 'Path' property 


Expected results: It would be more simple if 'Path' property could be empty and would mean, include given mask within base directory


Additional info:
Comment 1 Charles Crouch 2011-11-28 21:42:37 EST
(8:29:08 PM) ccrouch: jsanda: this seems a reasonable request: https://bugzilla.redhat.com/show_bug.cgi?id=755673, but for jon3 this should be a note in the docs right?
(8:29:34 PM) jsanda: looking...
(8:30:44 PM) jsanda: definitely a reasonable request
(8:31:01 PM) jsanda: just trying to remember if there was a good reason we required the field to be non-empty
(8:31:24 PM) jsanda: whatever the reason, must not have been good enough because i can't think of it :-)
Comment 2 Jay Shaughnessy 2011-12-09 14:46:05 EST
master commit 84c83f8760f6f37f7b7eed1b5e27346691901c11

It's now optional. It will be set to "." by default in the GUI. But even
if omitted will again get set to "." at the lower levels.
Comment 3 Mike Foley 2011-12-12 13:16:43 EST
verified RHQ 3, master.  observed the default set to '.' ... and additionally tested with that '.' omitted.
Comment 4 Mike Foley 2012-02-07 14:26:42 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.