Bug 755706 - grub.cfg does not correctly update after 3.1.1-2 kernel upgrade.
grub.cfg does not correctly update after 3.1.1-2 kernel upgrade.
Status: CLOSED DUPLICATE of bug 732654
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-11-21 15:20 EST by Rob Wills
Modified: 2011-11-22 00:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-11-22 00:42:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rob Wills 2011-11-21 15:20:58 EST
Description of problem:

After yum-upgrading to the 3.1.1-2 kernel, the grub.cfg menu entry is not correctly updated to reflect the newer kernel version. Specifically, the echo command still reports kernel version 3.1.1-1. Upon loaading KDE I verified that 3.1.1-2 was booted into via uname -r. Below is a copy of the current menu entry for the 3.1.1-2 kernel in my grub.cfg file. Notice the version error in the echo command.

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.1.1-2.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd1,msdos1)'
	search --no-floppy --fs-uuid --set=root 17e38c6f-969c-41f1-997d-399f49083832
	echo 'Loading Fedora (3.1.1-1.fc16.x86_64)'
	linux	/vmlinuz-3.1.1-2.fc16.x86_64 root=/dev/mapper/vg_rob-lv_root ro rd.md=0 rd.dm=0  KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=vg_rob/lv_root rd.luks=0 rd.lvm.lv=vg_rob/lv_swap LANG=en_US.UTF-8
	echo 'Loading initial ramdisk ...'
	initrd /initramfs-3.1.1-2.fc16.x86_64.img

Version-Release number of selected component (if applicable):


How reproducible:

Fairly, I'm assuming.

Steps to Reproduce:
1. Update to the latest kernel
2. Reboot
3. After grub2 loads, notice that it still says Loading Fedora (3.1.1-1.fc16.x86_64).
Actual results:

Incorrect version reported.

Expected results:

Correct version reported.

Additional info:

I know this is mostly cosmetic, but it could cause some confusion. I'm not that familiar with grub2, but based on the message at the top of the grub.cfg file telling you not to edit the file directly I'd imagine this isn't as simple as just changing the text and saving like you could with your grub.config files from legacy grub.
Comment 1 Andre Robatino 2011-11-22 00:42:38 EST

*** This bug has been marked as a duplicate of bug 732654 ***

Note You need to log in before you can comment on or make changes to this bug.